2

I have updated my Moto G yesterday to Android KitKat (4.4.4.) Before that I have disabled the stock Messaging app and I used Textra SMS app instead. Everything was working fine until the update. Then I was not able to send SMS from Textra or Hangouts because they were crashing. After resetting the app preferences and re-enabling the stock Messaging app, I am able to send SMS again from both the stock app and Textra. But I want to disable stock messaging app again, because it shows the incoming message preview in notification bar, and I don't want that. I want privacy with my SMS. This feature why I use Textra. How can I disable the stock SMS app?

4
  • Have you disabled the stock messaging app after re-installing Textra? You can disable it from Settings > Apps select Messaging and select Disable Jul 21, 2014 at 6:58
  • I am not able to disable it. this is the problem i am talking about. i want to disable stock message but i cant. the disable tab in the app info of stock messaging app is not activated.we have only force close option activated but it doesnt solve my problem..
    – Vikram
    Jul 21, 2014 at 7:02
  • 1
    Try if this works: Navigate to Settings > Application Manager > All Then select Reset App Preferences from the menu. (However, this will reset all your app preferences apart from the Messaging app). And now try to disable the app. Jul 21, 2014 at 7:10
  • I am using textra for 6months in my moto g default messaging app..i dont have any problems n it even works after updating to lollipop..goto settings->wifi and networks ->more -> default messaging app -> textra..
    – Lucky
    Feb 6, 2015 at 15:49

1 Answer 1

1

On Moto G the stock Messaging app is an integral part of the system, and should not be disabled even if you install other SMS apps. If you manage to disable it, other 3rd-party SMS apps (like Textra SMS in your case) will start crashing again.

Instead, you can disable the notifications inside the Messaging app by going to menu -> Settings, and un-checking the "Notifications" option:
Disable Notifications

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .