3

I have Cyanogenmod 11 M8.

I keep my contacts on the phone, not sharing them in the cloud, I prefer to run only AOSP software and FOSS applications from F-Droid.

Somehow I can't add/edit birthdays in the people app. Shouldn't this be a basic feature for a people application .

I know they are somewhere because the birthday adapter shows the imported birthdays from my VCF file in the calendar.

So how do I add a birthday?

1
  • I have the same problem with CM 12.1, so thanks for the question.
    – PythoNic
    Feb 16, 2016 at 20:15

4 Answers 4

3

On Cyanogenmod People, to see and edit the Events field (birthdays and anniversaries only available in this case), the People contact has to be in an Account, not on the phone only. I also do not use a cloud service for my own privacy reasons so I use MyPhoneExplorer app for PC synchronization and the associated but seperate MyLocalAccount app for Contacts storage, both on Play Store. If you decide to use MyPhoneExplorer/MyLocalAccount be sure to synchronize contacts into MyLocalAccount. When I realized this solution and installed MyLocalAccount (I had already been using MyPhoneExplorer) the older existing contacts did not synchronize with MyLocalAccount and I still had no Events field. I had to mass delete all contacts on the phone (easy with MyPhoneExplorer) and re-synchronize with MyLocalAccount. BTW, I use Outlook on my PC. Problem solved. Yes Android can be quirky but that's why we use it, right?!!

2
  • Thx. That is a clear bug then, will try Davdroid.
    – Janghou
    Sep 18, 2014 at 18:39
  • Davdroid will do the trick. Right you need an account.
    – Janghou
    Dec 7, 2014 at 16:34
1

The workaround I did was exporting my contacts to a VCF file then importing them on my old phone which has a field for birthdays, then edited/added birthdays and saved/exported the updated contacts and imported it into my newer AOSP phone.

Worked fine. The contacts app on my new phone doesn't display birthdays but they show up in Birthdroid

0

Once you are in the People app and have chosen a contact:

1) click menu --> edit

2) choose Add Another Field

3) select Special Dates (special dates defaults to birthday, but also included anniversary etc.)

I'm on CM11 M8 as well, works for me.

Also, might be worth flashing the latest gapps http://wiki.cyanogenmod.org/w/Google_Apps

3
  • 1
    Unfortunately the only fields I can select:Phonetic name,IM,Notes,Nickname,Website,Internet call,Address,Email,Phone. No Special Dates option available.
    – Janghou
    Jul 21, 2014 at 19:10
  • @Janghou You don't have "Add Another Field" button in the middle maybe more towards the bottom? Maybe try flashing the latest gapps too? wiki.cyanogenmod.org/w/Google_Apps Jul 21, 2014 at 19:19
  • The "Add Another Field" button only give above options. gapps? It looks like you can't keep track of birthdays unless you invite Google?
    – Janghou
    Jul 22, 2014 at 11:54
0

I don't think it's a bug. I thinks it's a Google vanilla Android "feature" that's transferred over to Cyanogenmod. Google is very driven to have you on their cloud and have an account with them.

1
  • 1
    It's a bug or Google is Evil. And that itself is a major bug and a shame, but one that will never fixed by Google unfortunately. BTW it's a bug in Android AOSP not in CM.
    – Janghou
    Sep 30, 2014 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .