0

Every so often I get this pesky dialog:

screenshot with error modal

I touch "OK" and it pops up again. This repeats until I reboot or don't use the phone for a while, then the problem clears up on its own.

Eventually I start using the phone and the problem occurs after a while again.

I used logcat and I see some stuff about a NullPointerException in some obfuscated WearableService code.

I'm using CyanogenMod 11-20140708-SNAPSHOT-M8-hammerhead. At the time of writing this is the most recent available snapshot.

I've tried upgrading to the snapshot I have now, and this seemed to solve the problem for a while. I've tried wiping the cache partition and wiping the dalvik cache.

I/Timeline(19904): Timeline: Activity_idle id: android.os.BinderProxy@428cc068 time:13198798
I/Timeline(  779): Timeline: Activity_windows_visible id: ActivityRecord{42320068 u0 com.android.settings/.SubSettings t28} time:13199067
V/Zygote  (21184): Switching descriptor 33 to /dev/null
V/Zygote  (21184): Switching descriptor 10 to /dev/null
I/ActivityManager(  779): Start proc com.google.android.gms.wearable for service com.google.android.gms/.wearable.service.WearableService: pid=21184 uid=10022 gids={50022, 3003, 1007, 1028, 1015, 1006, 3002, 3001, 3007, 2001, 3006}
D/ActivityThread(21184): handleBindApplication:com.google.android.gms.wearable
D/ActivityThread(21184): setTargetHeapUtilization:0.75
D/ActivityThread(21184): setTargetHeapMinFree:524288
I/MultiDex(21184): install
I/MultiDex(21184): MultiDexExtractor.load(/data/app/com.google.android.gms-2.apk, false)
I/MultiDex(21184): loading existing secondary dex files
I/MultiDex(21184): load found 1 secondary dex files
I/MultiDex(21184): install done
I/ProviderInstaller(21184): Insert disabled by gate 'gms:security:enable_conscrypt_in_gms_application'
D/GCM     ( 1343): GcmService start Intent { act=com.google.android.gms.INITIALIZE flg=0x10 pkg=com.google.android.gms cmp=com.google.android.gms/.gcm.GcmService } com.google.android.gms.INITIALIZE
D/assets  (21184): performGC: starting
W/dalvikvm(21184): threadid=13: thread exiting with uncaught exception (group=0x41efbce0)
E/AndroidRuntime(21184): FATAL EXCEPTION: WearableService
E/AndroidRuntime(21184): Process: com.google.android.gms.wearable, PID: 21184
E/AndroidRuntime(21184): java.lang.NullPointerException
E/AndroidRuntime(21184):    at kex.a(SourceFile:370)
E/AndroidRuntime(21184):    at kdq.a(SourceFile:390)
E/AndroidRuntime(21184):    at kef.e(SourceFile:240)
E/AndroidRuntime(21184):    at kef.a(SourceFile:270)
E/AndroidRuntime(21184):    at com.google.android.gms.wearable.service.WearableService.a(SourceFile:64)
E/AndroidRuntime(21184):    at khl.run(SourceFile:144)
E/AndroidRuntime(21184):    at android.os.Handler.handleCallback(Handler.java:733)
E/AndroidRuntime(21184):    at android.os.Handler.dispatchMessage(Handler.java:95)
E/AndroidRuntime(21184):    at android.os.Looper.loop(Looper.java:136)
E/AndroidRuntime(21184):    at android.os.HandlerThread.run(HandlerThread.java:61)
E/qcom_sensors_hal(  779): hal_process_report_ind: Bad item quality: 11 
I/Process (21184): Sending signal. PID: 21184 SIG: 9
W/InputMethodManagerService(  779): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@428bc5f0 attribute=null, token = android.os.BinderProxy@42e5b158
I/ActivityManager(  779): Process com.google.android.gms.wearable (pid 21184) has died.
W/ActivityManager(  779): Scheduling restart of crashed service com.google.android.gms/.wearable.service.WearableService in 1000ms
V/Zygote  (21225): Switching descriptor 33 to /dev/null
V/Zygote  (21225): Switching descriptor 10 to /dev/null
I/ActivityManager(  779): Start proc com.google.android.gms.wearable for service com.google.android.gms/.wearable.service.WearableService: pid=21225 uid=10022 gids={50022, 3003, 1007, 1028, 1015, 1006, 3002, 3001, 3007, 2001, 3006}
D/ActivityThread(21225): handleBindApplication:com.google.android.gms.wearable
D/ActivityThread(21225): setTargetHeapUtilization:0.75
D/ActivityThread(21225): setTargetHeapMinFree:524288
I/MultiDex(21225): install
I/MultiDex(21225): MultiDexExtractor.load(/data/app/com.google.android.gms-2.apk, false)
I/MultiDex(21225): loading existing secondary dex files
I/MultiDex(21225): load found 1 secondary dex files
I/MultiDex(21225): install done
I/ProviderInstaller(21225): Insert disabled by gate 'gms:security:enable_conscrypt_in_gms_application'
D/GCM     ( 1343): GcmService start Intent { act=com.google.android.gms.INITIALIZE flg=0x10 pkg=com.google.android.gms cmp=com.google.android.gms/.gcm.GcmService } com.google.android.gms.INITIALIZE
D/assets  (21225): performGC: starting
W/dalvikvm(21225): threadid=13: thread exiting with uncaught exception (group=0x41efbce0)
E/AndroidRuntime(21225): FATAL EXCEPTION: WearableService
E/AndroidRuntime(21225): Process: com.google.android.gms.wearable, PID: 21225
E/AndroidRuntime(21225): java.lang.NullPointerException
E/AndroidRuntime(21225):    at kex.a(SourceFile:370)
E/AndroidRuntime(21225):    at kdq.a(SourceFile:390)
E/AndroidRuntime(21225):    at kef.e(SourceFile:240)
E/AndroidRuntime(21225):    at kef.a(SourceFile:270)
E/AndroidRuntime(21225):    at com.google.android.gms.wearable.service.WearableService.a(SourceFile:64)
E/AndroidRuntime(21225):    at khl.run(SourceFile:144)
E/AndroidRuntime(21225):    at android.os.Handler.handleCallback(Handler.java:733)
E/AndroidRuntime(21225):    at android.os.Handler.dispatchMessage(Handler.java:95)
E/AndroidRuntime(21225):    at android.os.Looper.loop(Looper.java:136)
E/AndroidRuntime(21225):    at android.os.HandlerThread.run(HandlerThread.java:61)
I/Process (21225): Sending signal. PID: 21225 SIG: 9
I/ActivityManager(  779): Process com.google.android.gms.wearable (pid 21225) has died.
W/ActivityManager(  779): Service crashed 2 times, stopping: ServiceRecord{438a0f50 u0 com.google.android.gms/.wearable.service.WearableService}

Has anyone else run into this? Were you able to find any work-arounds? Is this more likely a hardware, gapps, or cyanogenmod problem? Where should I file a bug? Any ideas on how to further debug this?

  • 1
    What's your question? If it's "why is this happening?" the answer is probably, "because you're using an unstable build". – Dan Hulme Jul 22 '14 at 20:32
  • 1
    Well, there are no "stable" CyanogenMod builds. I have many questions: sure, "why?", but also, "has anyone else run into this?", "were you able to find any work-arounds?", "is this more likely a hardware, gapps, or cyanogenmod problem?" (e.g., where should I file a bug), "what kinds of things should I try?", "any ideas on how to further debug this?" – Adam Monsen Jul 24 '14 at 1:07
0

I got this issue with M10, disabling location completely solved the issue for me.

0

This helped for me (OnePlus One)

  1. Go to “Settings”
  2. Select “Apps”
  3. Swipe left until you in the ‘All’ column
  4. Click on the 3 dots in top right
  5. Select “Reset app preferences”
  6. Reboot phone
  7. Reselect preferred launcher

via http://blog.forret.com/2015/06/getting-rid-of-google-play-services-has-stopped-on-oneplus/

0

I've experienced this when doing a dirty flash from one rom (or stock) to another. A factory reset should clear this problem up. Backup your apps and wipe then restore

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.