I'm kind of disappointed, this morning I wanted to start my GT3 but I get this logo instead (sorry for the poor quality) :

Battery Logo

I've try AB testing with my Nexus 5 battery loader, both works on my Nexus. The GT3 flash sometimes and boot a few times but stop after less than 1 min.

I can't launch the tests (Power + Vol +) because it "needs battery to be above 3.4V.

Is the battery dead ?

3 Answers 3


Have you tried powering it off and charging it for 6 hours? If not, that should be your first course of action. If after charging it still doesn't power on, you may have either a bad charger or a dead battery (or some other strange bug I've never run into). If you have a different charger, give that a go for 6 hours and see what changes.

On my Galaxy Note 10.1 I've had that logo show up when I have very low battery. It won't actually power on until the battery is partially charged once you've taken the battery all the way down to zero.

Also, youtube: https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=4&cad=rja&uact=8&ved=0CEQQtwIwAw&url=http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3Dl1jrrVcQ8f8&ei=3HPSU9LIOIqiyASgmoCwDw&usg=AFQjCNH9B0sbXK8q_fWhhpNVUnHmlmcXxg&sig2=lVcDHD3B7ilruFW4gPiMQA&bvm=bv.71667212,d.aWw

  • "It won't actually power on until the battery is partially charged." With Android devices I've used, the minimum battery level to power on is 15%; lower than that, and you risk damaging the lithium cells, so the devices are programmed to shut down or refuse to start.
    – Zeiss Ikon
    Feb 4, 2016 at 12:41

After reading all the posts I tried to open the unit, but without luck. I then thought my computer USB port may be 3.4v or more, so I plugged in the Galaxy 10.1 in the USB port, waited about 20 minutes tried turning on the unit and walla it was charging. I did not see this fix noted anywhere in the posts and it may just be coincidental that it worked, but does not hurt to give it a try yourself....so glad I did not have to fool with the inside of my tablet.

  • 1
    This amounts to letting the device charge to 15% before booting. It's a pretty nearly universal Android solution; after a low-power shutdown, or a long time unused, you'll need to let it charge for a while (20 minutes or more) before it'll boot. Recommended you power off and let it charge overnight, then verify the device's charger is working correctly. Chargers aren't expensive...
    – Zeiss Ikon
    Feb 4, 2016 at 12:44
  • Great solution! Yes, let it charge some time before attempting to switch it on.
    – Yster
    Sep 19, 2016 at 9:31

I found the solution on this forum (in french, thanks god I'm french).

Your battery is too low, chances are you've left you tablet discharged and unused for quite a while.

Anyways, you need to unconnect the middle connector on top of you battery (you can see it in practice in this video: https://www.youtube.com/watch?v=humtforaj2w) then reconnect it and it should work again.

I'm amazed Samsung left such hardware bug in its device (Planned obsolescence?) but that's how it is.

Good luck

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .