0

For some reason Gmail won't sync to my phone. When i signed in with an account settings-->accounts-->google i entered my email address. Then I unselected everything for sync but the Gmail because Gmail is the only Google product I want synced on my phone. The problem is when i send a test email to my account through another email address I don't get a notification on my phone and I have to select the Gmail app then refresh and then the new email will appear.

Ideally if someone sends me a new email I will get a notification and I will know immediacy and I won't have to manually refresh the Gmail app to check for new emails. Is there something in the settings that I'm missing?

1

Two things to check given GMail is already set to sync.

First, double check you have notifications ticked inside the GMail app, this can be found by opening the left menu and opening the settings located at the bottom.

Secondly, in settings open data usage, then open the three dot menu and ensure that "Auto-Sync Data" is on and "Restrict background data" is off.

Note: These directions are based on Stock 4.4, if they don't correspond just let me know what phone and software version you have.

  • Thanks. Got if figured out. Took your advice and checked the Gmail app for notifications then checked data usage--> auto sync data. Notifications was checked but auto syc data was not checked. Sent myself a test email and it still didn't work. It turns out the setting was Gmail app-->inbox sound and vibrate -->sync messages -->changed from sync: none to sync: last 30 days. Now working. Thanks. – Jessica M. Jul 25 '14 at 23:02
1

I had the same problem. I resolved it doing this: My Contacts --> Menu --> Merge with Google Account

0

Try these steps, Hope it's may help you

1 Remove Your Gmail Account and Re-add it.

2 Clear Cache

3 Check Sync Settings on your Gmail App

4 Factory Data Reset

Not the answer you're looking for? Browse other questions tagged or ask your own question.