0

I have a Galaxy S3 and my 3g/4g suddenly stopped working. WiFi works fine, but how can I get my 3g to work again? I have already uninstalled apps and deleted unnecessary photos and videos.

  • How did you know that 3G is not working? Your apps/photos has nothing to do with it. Have you checked with your network service provider? It might be the issue from their side as well. – Pramod Karandikar Jul 28 '14 at 5:26
  • Need more info - what do you mean that it "suddenly stopped working?" Do you have the icon in the notification bar? Are you in data roaming mode? – IAmTheSquidward Jul 29 '14 at 15:41
1

Check that flight mode is not swithed on. This mode will disable any network (Wi-Fi, cellular network, etc).

Else, go to Menu | Settings | More Settings | Mobile Networks | Network Operators (Note: your menu options might be different due to the Android version installed on your S3) and reconnect to your telecommunication provider's cellular network. Note: You may need to select your telco provider's name when your S3 displayed a list of cellular providers.

Also, shutdown your S3. Then, take the battery out for 30 minutes. Reinsert the battery. Boot up your S3 and turn on Mobile Network option and see if 3G/4G has been restored.

Worst case, it could be an Android firmware's update that is causing the S3 to fail to connect to any cellular network.

0

Open your phone's dialer app(calling app where you type mobile no. to make a call) and type the following:

*#*#4636#*#*

It will open a mysterious looking menu before even you touch the dial option, yes! you won't need to dial it, but, just type in the code.

Touch on "Phone information 1" for SIM 1 in the menu in dual SIM phone, else it will show "Phone information" for a single SIM phone.

Scroll down, Make it look like "Set preferred network type: GSM auto (PRL)" by selecting "GSM" from dropdown menu.

Go back, exit the menu, reboot your device. If you still don't get 3G speed knowing that you have 3G enabled by your carrier(ex. Vodafone, airtel etc.): "Set preferred network type: LTE/GSM auto (PRL)" It should allow you 4G/3G speed as allowed by your network carrier and towers available in your area.

Be aware that changing the setting to a wrong option will lead your device showing "No network" and you won't be able to make calls. So, make note of the default preferred network type before changing so you can revert the changes back to it if you experience problem.

I hope it helps.

-1

Samsung phones usually take a while to switch on data. Wait for few seconds. Also try a reboot, that resolves the issue most times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.