-1

I need a bluetooth connection between Android Ice Cream device and Ubuntu 14.04 laptop.

I am able to transfer ordinary files through a bluetooth connection which is attached as a picture below.

But when i

adb connect xxx.xxx.xxx.xxx

within SDK directory,

i hope some connection appear, but could not.

Also as you can see below there is an "OFF" in the picture.

I wonder if this is the key problem about my bluetooth connection.

I think my server is up, because application can run on emulator.

enter image description here

  • 1
    This site works best when your question is a single question with a correct answer. You seem to be prodding around different things, suggesting there's really one problem to solve behind all your questions. It might be easier if you edit your post to be a single question, about what you're really trying to achieve. – Dan Hulme Aug 1 '14 at 13:30
  • 1
    Don't know – depends on – yes – no idea. +1 to Dan's comment. Plus, most of the topics have already be dealt with here multiple times, so while "cleaning up" your question you could remove them – after finding a fitting solution via our [search] and our adb tag-wiki, for example ;) – Izzy Aug 1 '14 at 13:54
0

I find bluetooth connections with Ubuntu to be a bit unreliable. I have tried it on a number of machines. I have also tried a variety of bluetooth adapters. I'm not sure if it's the various adapters that I've been using. I tried to find a recommended bluetooth manufactor specification, but didn't have luck.

It's not clear what you mean by

adb connect xxx.xxx.xxx.xxx

It's my understanding that you have to specify a port when you use the adb to connect (outside of using a direct connection from the USB).

You can have very reliable transfers and connection using your USB or your wireless. Since you make a reference to adb, I'm sure you already have the Android SDK package installed. So you have access to the adb transfer features (push/pull), using the USB connection.

To use the wireless connection for adb you have to first connect USB then activate the adb tcpip connection to your android. This is done by issuing the following command and specifying the port you want to use. After this activation you can unplug the usb cable and have adb wireless connection that will last until your android is rebooted.

$ adb tcpip 5123

In this example I specified a port that would be unlikely to be a default port for an automatic connection such as an avd.

After you have activated the wireless adb connection for the android you can connect to it by specifying it's IP address and port when issuing your connect command:

$ adb connect 192.168.1.102:5123

I believe your problems connecting adb has to do with your connection setup and parameters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.