I think I've came across to some sort of bug in Samsung Galaxy S5, (SW-G900W8), Android 4.4.2, (Kernel 3.4.0-1947824).

The problem is, after the mail account being setup correctly, the default mail client on the phone will not download all the mail but only the headers.

The "MAxEmailBodyTruncationSize" setting on the exchange server was set to 50KB , 100KB and unlimited but it has not solved the problem.

Another samsung phone (not the same model) gets the settings correctly (50KB, 100KB, unlimited respectively).

SO I'm pretty sure this has nothing to do with the server. Do you have any suggestions? Other than maybe using another mail client on the phone?


4 Answers 4


We had the same issue, and also tried setting it to "unlimited" without that solving the issue. We think the S5 is reading in bytes and S4 in KB. Finally, entering the limit in bytes solved it for us.

Can you try to put 1000000 in the limits and re-create your account on the S5, what choices of limits to you have while setting up your device at that moment?


This is how I would fix the problem on a Galaxy S4.

Open up the following menus in your phone (with the S5, they may be slightly different):
Primary Account
Sync Settings
Size to retrieve emails

Within this menu, you should be able to adjust the settings (on your phone) for "Size to retrieve emails" and "While Roaming". Make sure both of these settings are set to download more than "Just Headers".

  • No, the settings can not be changed (I know how to change them), the only option is "Headers Only" whereas on most other phones it lists all the options. 5K, 10K etc etc Commented Aug 3, 2014 at 0:57
  • Well good luck with the S5. I'm sorry I couldn't help ya.
    – pheidlauf
    Commented Aug 4, 2014 at 11:21

This is likely a bug introduced in one of the latest updates to Galaxy S5.

The functionality was working before for my phone: emails downloaded and you could set the size, but it stopped working during the summer (and I remember there was a system update downloaded).

I'm also using Exchange email on my Galaxy S5 and see the same symptoms (headers only downloaded, cannot change setting from Headers only). I have a second IMAP account configured, and that works normally (you can change the settings and message body is downloaded).

Unfortunately I haven't found a fix to this bug.


In case anyone is still looking for an answer, hopefully this will help out. All our S4,s, S5's and S6's had the same issue but only for the built-in AS client and only for those running Lollipop. So I did some testing and found something interesting:

The old set-activesyncmailboxpolicy is deprecated in our up-to-date E2013 servers. That command set the size as a straightforward number of KB i.e. a plain number with no qualifier. However, it appears the policy format has changed along with the editing command and it now takes a size qualifier of GB, MB or KB, with unqualified numbers now meaning plain Bytes. That suggests that the AS client in Lollipop is actually being quite strict as to how to read the new style, whereas Touchdown and Outlook clients seem to assume that unqualified numbers = KB as before.

So it's not really a bug, rather MS not thinking about backward compatibility as hard as they should have (how tough would it be to allow a B qualifier and assume unqualified was KB on all AS policies?). So all you need to do to 'fix' the issue you need to edit all your activesync policies with the new command and make sure to use an appropriate size qualifier. Btw - I've no idea if this applies to older versions of Exchange.

Example (for the Default policy - rinse & repeat for any additional ones):

set-mobiledevicemailboxpolicy -Identity Default -MaxEmailBodyTruncationSize 200KB -MaxEmailHTMLBodyTruncationSize 200KB

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .