1

I have a Samsung Galaxy S Duos 2 (GT-S7582) with two SIMs. I'd like to use one of those SIMs for everything telephony related, the other SIM for everything data related. I managed to set the first card to be the default SIM for outgoing calls, and I deleted the APN for the first card so that only the second SIM is used for data.

However, I still receive calls for the number of the second SIM. I also get the choice to call using the second SIM, which I do not want.

How can I disable receiving calls from the second SIM? How can I fix telephony/data even harder to the individual SIMs?

Android version: 4.2.2

EDIT: As a first workaround, I disabled the default ringtone for the second SIM. This way only the display lights up, which is easy to ignore.

  • You may be able to semi-disable incoming calls on one sim. A lot of cell companies allow you to set up call forwarding and other options using special codes. Look up the shorts codes available for the carrier of the SIM for which you wish to block calls. – Stephen Schrauger Aug 1 '14 at 20:22
  • I have two SIMs sharing a number, and only one of those is in the dual SIM phone. Sadly, if I change the settings you mentioned, this affects both of these sims - meaning that I also cannot receive calls on my other (non-dual SIM) phone. In other words, I need a solution that is configured for the phone only. – C-Otto Aug 1 '14 at 20:31
  • Really? I didn't know you could ever have two SIMs sharing a number. So if you call the number, both phones ring? – Stephen Schrauger Aug 1 '14 at 20:40
  • Correct. It's called Vodafone UltraCard. – C-Otto Aug 1 '14 at 20:51
1

You can achieve this by applying call barring on the SIM.

Although I know this is a different Andriod version, I am sure you will find something similar to this on my OnePlus 2.

Phone app > Settings > Call settings > SIM 2 > Call barring > Incoming call barring

  • Can you please improve your answer by making a sentence or adding details. – Maxime Jan 20 '17 at 13:02
  • 1
    @Maxime done as requested – Niel de Wet Jan 24 '17 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.