0

I hav moto xt1032. In short I can only access recovery and cmw. However it seems that either my usb debugging was turned off or there is somehow some sort of malfunction and in cmw adb does not detect my device (I have seen posts claiming that cmw does not required usb debugging off to use adb but still it does not work while it used to work previously). Mount as usb does not produce any effect neither

I need to somehow push a stock rom into my phone so I can use cmw to install it. Adb not working, sideload does not work as well. So is there any way out of this? Thanks

update:

0- my fastboot recovery command is working so I tried flashing recovery from twrp which works.But it can not for instance mount as usb neither.

1- I have tried using fastboot update rom.zip it says android-info.txt missing (and some more txts)

2- I can use fastbppt to flash files into to a flash partition but I guess they are not reachable by twrp or other recovery apps

1

Well okay instead of using recovery, I just followed the command line instructions in the rom zip file which goes as

 <step operation="getvar" var="max-sparse-size" />
<step operation="oem" var="fb_mode_set" />
<step operation="flash" partition="aboot" filename="emmc_appsboot.mbn" MD5="7ab4571da9966ecbe0455984ebe5d277" />
<step operation="reboot-bootloader" />
<step operation="flash" partition="partition" filename="gpt.bin" MD5="7778bf62e78dd8ed152e2234ba818fb1" />
<step operation="flash" partition="motoboot" filename="motoboot.img" MD5="b4cb31c6b875dbb13ae2a155ae44e305" />
<step operation="flash" partition="logo" filename="logo.bin" MD5="187908e994f5b42710d13dbb5126d6d2" />
<step operation="flash" partition="boot" filename="boot.img" MD5="2a0134f7dca00ab28ca3644febbe6bc7" />
<step operation="flash" partition="recovery" filename="recovery.img" MD5="25989942e94890fa2ab6e48fc488d569" />
<step operation="flash" partition="system" filename="" MD5="f6ea25745eab9f8368d5b276811ffa82" />
<step operation="flash" partition="system" filename="system.img_sparsechunk.1" MD5="d776d764c00627bcb7d0313657297ab4" />
<step operation="flash" partition="system" filename="system.img_sparsechunk.2" MD5="a17ebd36c45389a139e8f30e56241fa2" />
<step operation="flash" partition="modem" filename="NON-HLOS.bin" MD5="a964128abc6fa5ac4a253bd105ed6748" />
<step operation="erase" partition="modemst1" />
<step operation="erase" partition="modemst2" />
<step operation="flash" partition="fsg" filename="fsg.mbn" MD5="03d822a8e01a8edee85e12286dcc81ed" />
<step operation="erase" partition="cache" />
<step operation="erase" partition="userdata" />
<step operation="oem" var="fb_mode_clear" />
<step operation="reboot-bootloader" />

And the new system was installed suprisingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.