2

I am trying to use Linux Deploy on my rooted Galaxy S4 with stock Android 4.4 rom. But when I press install:

Updating configuration file ... done
>>> begin install
Checking mount points ... done
Checking installation path ... done
Making new disk image (1023 MB) ... fail
<<< end: install

I have already checked root permissions, tried to install in internal with /storage/emulated/0 and /storage/emulated/legacy, I have also tried to modify the image size but same results, how can I solve that?

  • try installing in /storage/sdcard1/kali – user73501 Sep 18 '14 at 6:03
  • In my device I don't have /storage/sdcard1, I tried /storage/sdcard0/linux but it doesn't work – Fabiusp98 Sep 18 '14 at 12:17
  • It seems a problem related to Samsung's Touchwiz roms, on Cyanogenmod 11 the software works. Maybe it's related to Knox oe selinux? – Fabiusp98 Sep 20 '14 at 4:39
0

It's related with the touchwiz kernel, beacuse when I flashed adam kernel it started working. I think it has to do with selinux set on enforcing

protected by Community Nov 13 '14 at 15:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.