2

I'm trying to install another rom on my Samsung Galaxy S3 and when in the Clockwork Recovery Mode, the ADB quits recognizing the phone. When I boot to the SO, the pc normally recognizes it, I gave authorization, I have usb debugging on. When I boot into recovery mode, it quits recognizing, thus not letting me upload the rom.

  • Assuming your computer is running Windows, try re-installing the USB drivers while the phone is in Recovery mode. – Chahk Aug 5 '14 at 20:18
  • Is there a reason that you can't just copy the ROM file/s to your device's memory while it is on? Additionally, I've had much more success with TWRP than CWM. The latter has been much buggier in my experience. – filoxo Aug 6 '14 at 4:52
  • @Chahk Sorry to mention, yes. Windows. And I tried that already with no success. I also tried installing alternative drivers, as instructed in some Cyanogenmod official wiki pages. – Sergio Aug 6 '14 at 8:16
  • @filoxo I didn't know I could reach the same locations from the clockwork recovery as I can when the phone is connected. Could you give some more insight on that? Like where I should put the rom in order to later open from the recovery? Meanwhile I'll check out your suggestion. – Sergio Aug 6 '14 at 8:17
  • I can only really speak for TWRP since I haven't touched CWN in ages. I usually download the ROM.zip file to my sdcard root (which is actually emulated, but it should be accessible while in recovery anyway). TWRP has a Mount option that you should use if you have a physical SDcard that isn't automounted. Then use that file to flash whatever you want. Flashing usually does not delete anything from your data partition (which is where the emulated /sdcard is mapped to). Feel free to chat if you need more info. – filoxo Aug 6 '14 at 17:24
1

I had similar situation with Xiaomi Mi3 W. It was totally working while in OS, but not recognized by ADB when in recovery (CWM). In this particular case it was driver problem. When phone was working normally, it identified itself as MTP device, so Windows had neccessary drivers already installed. But when in recovery mode, it isn't neither MTP nor USB-flash device.

Check Windows Device Manager, it should show some unidentified device (with yellow question mark). If so, right-click it and choose "Update driver", then install standard ADB generic drivers provided by Google (they are labeled "Composite ADB Interface" or "ADB interface" or something like that). Then reconnect the device and see, if adb devices shows anything. It should now display your phone id and say it's in "recovery" state.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.