3

I'm using a Dutch Nexus 5 with stock Android 4.4.4 KitKat but have the voice language set to English (US). I have the latest files for offline speech recognition for English (US). Google Now, "OK Google"-detection and audio history are enabled, and it all works like a charm. It instantly responds to "OK Google", and transcribes my (English) statements flawlessly.

However, Google Now always starts a search. Whatever I say, it is never recognized as a command. So, whether I say Say 'How are you' in Spanish, Set alarm for 8 PM or just Help, it just starts a Google search on the exact phrase I said. Obviously that's not very helpful. How can I fix this?

(There are only three commands that I've found that do work: call, dial and text.)

  • Is your Nexus 5 stock, or running a custom ROM with GApps? – Chahk Aug 5 '14 at 18:54
  • Also, you say "English (US)" is selected. Is this in Google Search app preferences, or system-wide? – Chahk Aug 5 '14 at 18:57
  • I believe the system-wide language setting must be set to English. I'm searching for confirmation right now. Can you try this in the meantime? – Chahk Aug 5 '14 at 19:02
  • @Chahk I can confirm. Due to your previous comment I tried changing it to English, and lo and behold voice commands worked. I was just typing it up as an answer as you commented. – Daniel A.A. Pelsmaeker Aug 5 '14 at 19:03
  • Found confirmation: Voice commands only work when the system is set to the following locales only: English, French, German, Italian, Japanese, Korean, Russian, Spanish, or Brazilian Portuguese. – Chahk Aug 5 '14 at 19:25
3

According to Google's help pages on using Voice within the Search app, the Voice Actions only work for a limited set of languages:

For most of these tips, you need to be using Android 4.1+ in English, French, German, Italian, Japanese, Korean, Russian, Spanish, or Brazilian Portuguese. Some voice actions are not available in all languages and countries.

They are not referring to the Search app's "Language" setting, as that only governs language in which search results are returned. You must change the system-wide Language setting to one the supported locales under Settings -> Language & input. Unfortunately there is currently no way to use Voice Actions under other locales. Google however are always improving their Search app, so it's possible that Voice Actions will become available in your country's language soon.

2

Setting the system-wide language to English (US) (in addition to having the voice search language set to English (US)) made Voice Commands work. I tried this because of a comment by Chahk.

However, I'd rather see a solution where I can have my system-wide language set to something other than English.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.