Device: Galaxy Nexus
Android: CyangenMod 11.0 (Android 4.4.4)

The IT department of my company doesn't support access of Mac devices to its network, but it does for Android devices. So I would like to connect my macbook (Mac OS X 10.9.4) to the internet by tethering my phone's Wi-Fi connection. Bluetooth tethering is reliable, but rather slow (max 200KB/s download speed, in reality it is rather something like 80KB/s).

So, I tried to use the USB tethering with the help of HoRNDIS (release 5), which is magnitudes faster (22MB/s) than Bluetooth tethering. However after a while (some minutes), the connection is lost. To restore it, I have to unplug the USB cable, plug it in again and retick the checkbox 'USB tethering' on the 'Tethering & portable hotspot' page in the 'Wireless & Network' settings.

In order to solve this problem, I tried the following:

  • Enable 'Android debug mode' & 'ADB over Network'
  • Screen always on

Unfortunately, these attempts didn't work.

Does anyone have a similar problem or workaround?

  • I'm having the same problem. I've tried with HoRNDIS (rel 4 & 5). USB tethering will drop after a while and come back. I'm not sure if my Galaxy Note 2 having problems with the USB cable. But now you've posted this, I'm pretty sure it's not because of the USB cable. I've used the Xiaomi Redrice phone for USB tethering before, and it's really good. There is no data dropping. I'll look for a workaround. Commented Aug 26, 2014 at 9:02
  • I used different USB cables, but the problem persisted. My USB socket seems to work well, no issues with charging or with data transfer.
    – eavsteen
    Commented Aug 27, 2014 at 18:35

2 Answers 2


I faced similar lost internet connection issues with galaxy y tethering. Had to unplug and plug in the cable; again select tethering. However, i noticed that orientation of the cable just outside the socket mattered. There is room for movement even after usb is plugged in the phone. In this instance, when i so arranged that the usb cable is as lateral as possible to the phone midline(had to use anatomy); there was no lost connection.

  • I use USB extension cord with iphone 5 and Windows 10 PC and have same problem. After a few minutes the internet sharing cease to function and I have to unplug and plug cable. But I noticed that it happens more often if I physically move USB cable. It seems that physical connection in USB port is broken for fraction of second and this causes loss of internet sharing. Commented Dec 6, 2020 at 19:24

Make sure that you disconnect the other network connections / Ethernet while USB thether... I just went through 5 days of page hangs, and then I switched my ADSL box (it was disconnected anyway) and it put the tether on a new network name called network 5 and all the pages come through now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .