0

I decided to clear my data usage stats on my Android in Settings > Data Usage from the terminal emulator app, but the first command came back with the error "No such file or directory".

The first command: rm /data/system/netstats/*

The same command that worked: rm /data/system/netstats/*

Here's a screenshot of what happened.

enter image description here

I'm running the supernexus custom ROM on android 4.4.2 on my Samsung Galaxy S3-19300

I was sure of the directory to clear of the stats but had to try a different directory in the latter commands, and the same command worked fine in the last line, what could've caused this?

0

Hard to tell for sure without "direct access", but here are the most likely answers:

  1. there are no files in that directory, so nothing to remove
  2. you cannot use rm to remove directories (that's what rmdir is for)
  3. that will most likely fail as well, since /system is usually mounted read-only ;)
  4. the original command succeeded at last: most likely some file was created there in the meantime.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.