I was trying to release some internal memory on my CUBOT GT-99, so I started disabling some system apps using one rooted app. One of apps I was disabled is system keyboard because I don’t use it beside Swift Keyborad. I was totaly forget that I use system keyboard whan I turn on my phone, becouse I encrypt my phone, so I need system keyboard to enter the password. Now phone ask me for decrypting password but don’t show me the keyboard, so I can’t enter password and can’t system run.

One of my idea is to use Android SDK, if there's some tool or something (?) to use PC Keyboard instead of disabled system keyboard (I don’t know anything about Android SDK).

If there is no other option I'm ready to do hard reset, but I don't know how to do this in this situation.

Please can someone give me any other idea and tutor how to solve this.

  • 1
    Since you are rooted, I assume you have installed a custom recovery like ClockworkMod. Can you boot your phone in recovery mode? You should be able to perform a factory reset (a.k.a. wipe) from there.
    – Chahk
    Commented Aug 7, 2014 at 13:16
  • If the device were not encrypted, you could use ADB to re-enable the app (pm enable). But I doubt that works with encryption turned on and the device not yet unlocked. So I'm afraid the full factory-reset Chahk suggested is the only way out.
    – Izzy
    Commented Aug 7, 2014 at 14:34
  • No I didn't install ClockworkMod :( How to do Full Factory reset in this situation?
    – djlabat
    Commented Aug 7, 2014 at 20:34

5 Answers 5


I don't think that the above answer is quite correct as when you enter in "recovery mode" (on an encrypted device) the /sbin/sh pm command can no longer be used since the device needs a password for decryption. (I even decrypt my phone and still could not perform the command :(

Also thinking about it more running that command to re enable a package would open up a security hole for encrypted devices so this command would of run useless on an encrypted device (which is not "decrypted" in the first place)

If you have TWRP installed as your recovery they have their own keyboard layout which you can enter in your decrypt password and then use one of your backups to revert back (which I hope you have done) to recover your keyboard layout.

Otherwise you'll need to install/flash back to your stock rom :(



First of all, I didn't know how to enter in Recovery Mode on CUBOT GT-99, but accidentally I enter in it, and I want share this with you because I didn't find it on internet.

Press POWER for 1 sec and than release...phone vibrate...Immediately after vibration press and hold POWER & VOLUME+ button.

In recovery mode it alows me to:

apply update from ADB/sdcard/cache

wipe data/factory reset

wipe cache partition

backuo/restore user data

I tried to establish a connection with the ADB, but it did not work because of encrtyption. I made a backup user data and after that I dona Factory Reset.

The new system had the same problem, there is no system keyboard. so I've installed the Swift Keyboard from computer using the command adb install %PATH_OF_PACKAGE_ON_PC%.

I finally had some keyboard with which I could enter my email address and password to enter in Google play. There I installed Root App Delete (with which I had previously disabled the system keyboard), to re-enable the system keyboard.

In the end all I needed is to go to the system recovery and restore user data witch i made before Factory reset.

That's it. :)


A simpler solution

I had the same issue, but I don't have an SD card in my Moto X. That means, if I backup then factory reset, my backup will be gone too.

I found another solution. You can just reflash the Google Keyboard to your device using TWRP. The zip I used is here: https://www.androidfilehost.com/?fid=95855108297851240

If you don't have TWRP recovery, you can flash it from fastboot.

After flashing, the keyboard should work again and you can enter your password for decryption.


I think that if you entered in recovery mode (any of them) you can use Adb to enable frozen apps. It can be done throught the command "adb pm enable packagename" where packagename the app of the keyboard . if you dont remember the exact name use the command "adb shell pm list packages -f" to return all the installed apps and find there the disabled keyboard. An excellent tutorial of how to use adb can be found here http://www.vogella.com/tutorials/AndroidCommandLine/article.html by Lars Vogel.


This worked for me : connect usb OTG cable and a regular pc keyboard, then power on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .