0

have a NanoPC-t1 device and I'm running Android 4.2.2 on it. I want to install my gy-gps6MV2 module and make it work as the device GPS.

Do I need root access? (I already tried to root device with SuperOneClick) I've pluged it into my UART serial port, when I run: adb shell root@android:/ # cat /dev/ttySAC0

All I get is white space outputs, while I know it's the gps module output but I can't figure out why I get white spaces.

When I connect my GPS module via a rs232 to usb I can read the GPS data like a charm (using cat /dev/ttySAC0)

What am I missing? please help me fix this problem, I'm struggling with it for two weeks...

0

I figured it out, the problem was originating from NanoPC-t1 config which used the USART port for output debug. It was over-writing the gps output.

I used Android Serial Port API, and rooted my device. Because accessing ttySAC0 port, needs root access.

I wrote my own NMEA parser to receive GPS fixes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.