0

Some time ago I've been able to connect my "Smart"phone to my Ubuntu 14.04 PC as mass storage device with an micro USB cable hitting the ~"Activate USB storage" (translated) button in the notifiaction pull-down panel which appeared after the cable has been plugged in. Now, establishing an USB connection is tried for > 3 minutes and then times out; the animated waiting icon (spinning circle in which the button to activate the USB storage is transformed to) changes back to the button to activate the storage. Some infos:

  • occurs 100 % of the tries
  • restart doesn't help
  • cable seems fine because charging works
  • Android 4.0.4 on SansuiCosmic SP 1001 trying to connect to Ubuntu 14.04 with Linux 3.15.9 without problems with USB experienced so far.
  • I've never seen an "establish connection" button, could you get a screenshot of this? What mode are you trying to connect in? ADB/MTP/PTP/Mass device? – onik Aug 12 '14 at 7:26
  • 1
    "cable seems fine because charging works": disagreed on the reasoning. USB plugs have at least 4 (some have 5) pins in use. 2 are for power, the other two for data. So if one of the data connections got broken, it would still charge fine. // Have you tried a different cable? – Izzy Aug 14 '14 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.