0

I've just gotten a Samsung Gear Live and I get a card for a System Update (I currently have KKV81). It says "Touch to install", however nothing happens when I touch it. I swipe left and select "Open" and I get asked "Download complete. Ready to install?" Again, nothing happens if I press the tickmark to install it.

There are a bunch of other minor issues, but I'm hoping the software update will fix them.

I've unpaired, re-paired, restarted, factory reset and just about anything else, but nothing seems to make a difference.

Any ideas what might be wrong?

1

I had the exact same problem. This is how I solved it:

  1. Hold the button on the right hand side of the watch down until the screen goes off (about 10 seconds).
  2. Release the button.
  3. The watch "rebooted" and came up with system update message that said swipe left to install
  4. Follow instructions on screen
  • I had tried that already with no effect. The 10 second button press is just a restart of the watch. I did the same from the menu but it didn't help. – QuantumPete Aug 13 '14 at 14:58
0

So today it worked for me all of a sudden. I think it was because I was no longer on my home wi-fi. I was on 3G data connection. I went through all the same steps and this time when I touched the tick mark, it installed and rebooted. For anyone else suffering from this, try taking your phone off wi-fi, waiting a few minutes to make sure it's fully connected to 3G and then try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.