11

I noticed recently that, when I would use my phone after it had been sleeping, wifi wouldn't be connected and it would have to connect. I went into advanced wifi settings and ensured that "Keep Wi-Fi on during sleep" was set to "Always", but the problem remains. Any ideas?

I have an HTC One and AT&T.

Update #1: Went through troubleshooting with three different HTC techs. The last effort was to clear the boot partition cache and factory reset the phone. After doing both, however, the issue remained. I learned that the AT&T software is out of date and actually has never been updated since I've had the phone for 16 months. I'm waiting for a level 2 HTC tech to send me the latest version.

  • Do you have a 3rd party battery saving app installed? They usually turn all connections off when your phone is in deep sleep, only refreshing it for a minute every hour or 45 minutes depending on the default settings. – roro Aug 13 '14 at 15:22
  • I do not have a battery saving app. – im1dermike Aug 13 '14 at 19:12
8

Just as an addition: I stumpled across the same (plus another problem) while upgrading my nexus 5 from Lollipop to Marshmallow. Every time when the phone was at sleep mode (for example: while driving my car and phone rested in the pocket) and I walked into a know wifi it did not auto connect.

Usually when I arrived at work, as soon as I exited at the parking lot I got notified for incoming mails or messages, but not anymore on Android 6. As soon as I unlocked the phone wifi automatically connected and everything was fine. But I always forget to do this and It sometimes took hours before I realized I haven't done this step and messages won't get sent to me since I was not connected to the wifi until I picked up the phone from the pocket and unlocked it once.

I looked through all the settings and policy stuff, and finally I found something that worked:

Under Settings -> Power -> ... -> Power Optimimization you can switch the list from "unoptimized apps" to "all apps". Then search for "Google Connectivity Services" and disable the power optimisation for this system app.

After I've done it finally autoconnects to known wifis while my phone is in my pocket.

UPDATE I just wanted to leave a note, that there was a small update a couple of days/weeks ago that brought back the not autoconnect issue to me, Power Optimization did not work for me anymore. Still have this issue, I will do a clean Android 6 install in the next weeks and look if the issue still exists. If yes I will stick with Android 5.x

UPDATE2 There was another update a while ago that almost "fixed" this problem.

  • I don't see "Power" under "Settings" in Android 6.0... – Michael Dec 28 '15 at 18:54
  • I found it under Settings -> Battery -> (pull down menu in upper right) -> Battery Optimization. – Michael Dec 28 '15 at 19:10
  • I am glad you found it but I am afraid they changed something. The last small update brought back this issue to me, so the optimization does not work anymore for my nexus 5 at least :/ I can conclude 3rd party app since I don't have much installed besides the default Google apps, Telegram, Netflix and 2048 :) – Ello Dec 29 '15 at 12:46
  • Yeah, I tried it and it seems to help but it still doesn't retain Wifi 100% of the time... which is unfortunate when I am in an area where I have Wifi coverage but no cell coverage (Google Fi...) – Michael Dec 29 '15 at 17:30
  • It's happening while on AC power with the battery fully charged. – Kaz Jan 23 '17 at 19:01
4

On Marshmallow, go to settings, battery, pull down battery optimization, All apps, select Google Connectivity Services, select not optimized. This solve the problem for me. WiFi always stays on, even during sleep.

0

What a nightmare. I've spent the last 2-3 weeks trying to have HTC work with me to resolve the issue. Their customer service had been frustrating.

After factory reseting my phone to no avail, it was concluded the only possible cause of the issue is that my software was outdated. It turns out, my phone had never updated its software. Ever. This is something I would expect to be done automatically, but HTC wouldn't accept blame nor would they blame AT&T or me for not manually checking for updates constantly. They also somehow don't have access to any of the updates I missed (that they own). An escalated tech support person said to have the software updated, I'd have to send my phone in for repair or he'd have to contact "corporate" to gain access to the updates. What?

In the meantime, he suggested a couple troubleshooting steps which, after reviewing my ticket, he saw had not been tried. One of them worked and that was to go to:

Settings > Power > Power Saver. Turn Power Saver off and uncheck Data Connection. I'm not exactly sure what this does - most likely results in my power draining faster - but it works and I don't feel like dealing with HTC anymore.

To be clear, I don't think this is a perfect solution, more of an acceptable stop-gap. I assume that having the phone software completely up to date would resolve the problem, but since HTC is unable to provide me with their updates, this is what I have to go with. Hopefully this helps someone else.

0

I had same problem and after mouths I tryed to switch from Settings->Smart battery saver (5.1) to ON from OFF and i saw it work, my Wi-Fi keep connected in sleep mode. I think on is off and off is on and nobody know it (+ google) or this is only at my phone... I don't know but this worked for me xD

0

I've tried everything this discussion proposes but it didn't fix my problem.

What fixed it, was enabling "Performance" Battery Mode instead of "Balanced".

Please note that I have CM13 on a LG G2 (d802) but I guess this problem excisted across many devices (I've read about SGS7 too).

I hope I helped ! That was my first ever response to stackexchange! :)

0

I had this same problem and had done just as the author: "went into advanced wifi settings and ensured that 'Keep Wi-Fi on during sleep' was set to 'Always'"

However, to solve it I just toggled the setting: I switched from Always to Never, backed out to ensure the setting took effect and then set it again to Always and backed out.

This solved my problem.

0

I solved this problem by changing the modem setting. The latest versions of Android has problems with the Wi-Fi channels 1 and 13, so a better way is to set the transmission channel number of the modem or router from automatic to a middle channel, e.g. channels like 5, 7, etc... Because I've done this change the connection is working great and never disconnects even when my phone is sleeping or screen is off.

  • Don't use ALL CAPS because that looks like you're shouting and it's hurting my eyes and ears. – iBug Jul 23 '17 at 14:02
-1

Im 100% sure it is all about IPv6 type of connections. I was having IPv4 and it was all OK. Switched to ipv6 and this problem accrued.

  • On which Android device and Android OS did you try this successfully? Are you absolutely certain you had the same problem as mentioned in the question? – Firelord Jan 15 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.