4

My mobile is Lenovo S920 running official Android OS 4.4.2.

I am trying to install cwm recovery through fastboot. I tried executing the command

fastboot flash recovery recovery.img

But I am getting the error as partition 'recovery' not support flash. Please any one help me to fix this. Whether I need to change anything on the recovery partition?

  • 1
    You need to edit your question to tell us what phone you have and exactly what commands you ran, before anyone can help you. – Dan Hulme Aug 14 '14 at 8:11
  • have you rooted your phone? – Itzik Samara Aug 14 '14 at 9:38
  • No, trying to root it. Tried all the methods, Framaroot, Vroot, one click... nothing is working. So planned to change the recovery first and then install super user from there using Install Zip option. – Guna Sekaran Aug 14 '14 at 9:56
4

Looks like this phone does not support flashing partitions via the fastboot utility. According to this guide you will first need to root the phone by following the instructions from here:

  1. Download the latest version of Framaroot and side-load the APK.
  2. Open Framaroot select the action to perform. Select “Install SuperSU”.
  3. In the rooting menu, Select an exploit in list above to potentially root your device as Barahir or BOROMIR and proceed further. The rooting has now started and you will be getting an awesome success message.
  4. After the end of the installation process, reboot your device and you can now enjoy the Rooted Lenovo s920.

After the phone is rooted, you will need to do the following:

  1. Download CWM For Lenovo S920 and extract it to the root of your SD Card.
  2. Install Mobile Uncle App from Google Play Store.
  3. Once installed, launch it from your app drawer.
  4. Select “Recovery Update” from the menu. The tool will search your SDcard automatically and find your “recovery.img” file. Select the recovery under “Recovery file in SDCard”. Click “OK”
  5. It will ask you if you want to reboot into recovery. Click Ok to confirm that your phone boots in CWM recovery.
  6. If installing Recovery.img doesn’t work on First Time, no problem, after reboot install it again through same procedure.

This installs the recovery temporarily. If you wish to install it permanently, also do the following:

  1. Install Root Explorer and run it.
  2. Mount the system partition to Read/Write.
  3. Navigate to /system/ and delete the file named "recovery-from-boot.p".
  4. Re-install CWM as described above.
  • Framaroot is no more working. It was working well when I have 4.2.. Now the mobile is updated to 4.4.2. I received this update OTA from Lenovo 2 days before this post. – Guna Sekaran Aug 18 '14 at 6:06
  • Mobile Uncle doesn't exist. – IgorGanapolsky Aug 3 '16 at 14:14
0

Try using SP Flash tools. It's for MediaTek devices like yours. You will need the correct drivers. Look this up on XDA, there is a fair amount of risk involved. You MAY BRICK THE PHONE. I have a Canvas Knight, and the same problem occurred with me too. This ASE post (Thanks to @Gulam Mohammed for his detailed answer) has further guides (although it is not excatly for your device, but it is relevant).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.