2

A few days ago, my sd card became unusable. I tried to copy a few mp3's from my laptop (win 7) to my phone (Samsung S2 plus, running android 4.2.2) and the load bar didn't even move an inch. Eventually I got an error saying "This file cannot be copied. 1) Try again 2) Abort".

The most annoying part is that I backed up and deleted all files (to clean the sd card) an hour earlier, and now nothing works. I tried writing files using usb cable over both MTP and camera mode, without any results. I tried apps on the phone, and still the same error. The sd card is inserted correctly and does not appear to be damaged.

I have heard about the kitkat not being able to write files to sd card (like this forum post) but I think that is only for android 4.4. I have been running 4.2 for a while now, and have never faced this issue before. Phone works perfectly except sdcard.

EDIT: My phone actually tried to launch a software update, but since I wasn't connected to a WIFI nothing happened, no loading bar and no update was started.

  • I'd first check if the Android logs give some clue. If you never read them, please take a look at How can I view and examine the Android log? and our logging tag-wiki to get started. – Izzy Aug 14 '14 at 15:31
  • @Izzy Thanks for the tip! I checked, and there seemed to be a few corrupt files on the sdcard. Putting it in another phone and deleting those files made the trick. As you mentioned in the comment on the answer below android mounted the card as readonly. – Pphoenix Aug 15 '14 at 6:34
  • 1
    Glad to read you were able to solve the issue! I've summed up things in a separate answer, so it might help others in similar situations (and you next time, where the culprit might be a different one). Be welcome to accept it (tick the check-mark next to it), which makes it easier for others to identify questions solved :) – Izzy Aug 15 '14 at 12:07
  • @Izzy Wow! Great answer! – Pphoenix Aug 15 '14 at 12:21
  • 1
    Thanks! Just figured I had put that into a nice graph before, see our external-sd tag-wiki :) – Izzy Aug 15 '14 at 12:31
2

How to find out what's going on

As this problem can have many causes, it's important to first figure out the real culprit. Without knowing that, attempted solutions are nothing but guesswork, and the process nothing but try-and-err. So here are a few steps:

  1. Is it a hardware error on the card?
    Put the card in a different device. It the same problems occur there, we can rule out your problem is with the device, and it's rather the card.
  2. Is the card corrupted?
    You can put the card in a card reader, attach it to your computer, and have it checked there. With a terminal app, you could try the same from within your device, using the /sbin/fsck.vfat tool – but on your computer, graphical tools might assist you.
  3. Check the Android logs for related errors:
    Our logging tag-wiki gives you some hints on how to do this. Especially useful might be our question on How can I view and examine the Android log?

The third step lead directly to the cultprit(s) in your case: corrupted files. Deleting those made the card usable again. So next, let's check a few possible causes:

What could be possible culprits?

  1. the card could be physically corrupted.
    In this case, the same errors should occur on other devices, and as well on your computer when using a card reader. Only solution for this is to replace the card with a new one, as a "physical repair" is not possible.
  2. there might be problems with the contacts.
    Here a few things could be tried, like cleaning the contacts of the card. If the same problem occurs with any card you put in your device, it's rather the device itself – in which case you'd have to send it in for service.
  3. logical corruption of the cards :
    The file system can get corrupted. This e.g. happens when you disconnect the card without cleanly unmounting it first. While in such a case the same problems should show up in any device using the card, some might be "more tolerant" on errors than others. So it doesn't hurt to check the file-system for errors – see step 2 in "How to find out" for checking. If there are errors found, the same tools usually can solve them. Re-Formatting the card would be a last resort for this as well.
  4. corrupted files on the card:
    The card might be physically perfect, and have no issues in the file-system. But in some cases, corrupted files might led to problems as well – especially if occuring on "central files" Android is always looking for on the card when it's mounted (in the /Android subdirectory, or while scanning for media). If you can read the card using a card-reader on your PC, you can make a backup there and then format the card – copying the files back one-by-one until the error occurs again, and then skip those corrupted files. Easier approach is the one you've taken on my recommendation in the comments: check Androids logs (see step 3 on "How to find out"), and simply delete the culprits (again, via a card reader – as you cannot do so on the device itself, which doesn't correctly mount the card anymore).

Possible solutions

have already be mentioned along the lines, together with the related causes:

  • cleaning the contacts of the card
  • checking the card for file-system errors and, if there are any, have them repaired
  • formatting the card1
  • checking the Android logs for other hints (e.g. corrupted files, which then should be removed)

1: remark: switching to an alternative file-system type does not affect whether formatting helps, but rather might lead to additional issues – as not all file-system types are supported by Android. Which are, differs from device to device, and depends on the used: VFAT is the default shipping with most cards, and hence always supported. EXTFS is mostly supported as Android uses it internally (but might not be automatically detected, as it's not expected here). Other types such as NTFS or HFS are very unlikely to be supported

0

If partition is formatted as ext2 and mounted as ext4, then you can only read partition. Check your mounting script!

  • 1
    There is not enough evidence to assume that OP's external SD card uses an EXT filesystem. Often, external SD card is formatted with FAT filesystem in Android. – Firelord Dec 12 '15 at 13:57
-2

Try your SDcard with other mobile or a card reader. Make sure its properly working.

  • I tried the sd card in an old nokia 5130, worked perfectly. Tried again in my android, did not work. – Pphoenix Aug 14 '14 at 8:45
  • Have you tried formatting the SDCard? – Guna Sekaran Aug 14 '14 at 8:46
  • Yes, formatting is the only thing I am able to do at the moment. However, problem is still there. – Pphoenix Aug 14 '14 at 8:48
  • Try formatting by changing the file system may work. – Guna Sekaran Aug 14 '14 at 8:50
  • How do you mean? Like change from/to NTFS/FAT? – Pphoenix Aug 14 '14 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.