0

Google backup seems not to be working on my Nexus 4 with CM11 (snapshot M9). I've the Google Apps installed (gapps-jb-20130301-signed.zip), but when I try to list the transports, here's what I get:

$ adb shell bmgr list transports
  * android/com.android.internal.backup.LocalTransport

Is this expected?

Under Settings -> Backup & reset I find this screen

Backup & reset settings

  • I have never, ever installed cyanogenmod over the last few years without something weird happening, bugs and missing features. – RossC Aug 14 '14 at 18:04
  • You installed a gapps package that's intended for Jelly Bean. Of course it won't work (correctly). Anyway, I recommend using PA-GApps if you ever do a clean install in the future. It works with pretty much any custom ROM, it's up to date, and very customizable. – nyuszika7h Feb 8 '15 at 15:35
0

I think this issue is ROM related, the .BackupTransportService should be there. I've checked the list on a similar setup (LG Optimus G, CM11 20140813 nightly)

bmgr list transports
  * com.google.android.backup/.BackupTransportService
    android/com.android.internal.backup.LocalTransport

Have you tried newer CM versions?

(Also see this thread at XDA from Nov. 2013)

0

Just to let you know that my issue seems resolved installing the latest gapps package suggested by Cyanogenmod wiki: gapps-kk-20140606-signed.zip.

I followed these steps:

  1. download zip
  2. copy to /sdcard/
  3. reboot in recovery
  4. install zip
  5. reboot device

During the first boot the device asked me for a backup account, but in the Settings I had still Backing up to debug-only private cache.

Then I set the new backup transport with

$ adb shell bmgr transport com.google.android.backup/.BackupTransportService

Without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.