-2

I'm trying to install ADW or Launcher3(or really any other launcher) on a device

Whenever I start ADW or Laucncher3 from am it just keeps looping back to 'Complete action using' regardless if you say just this once or to save the default.

The only way anything happens is if you select the OEM launcher again.

It seems like maybe I'm missing some core libraries.

What missing .so or apk or jar etc might cause this? How can I get an alternate launcher to work? I have tried adding Velvet.apk and a gcore.apk but it seems maybe it is more low level

Logcat shows a null pointer error and then the launchers force closing and also:

E/AndroidRuntime( 928): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.android.launcher3/com.android.launcher3.Launcher}: java.lang.UnsupportedOperationException: Can't convert to dimension: type=0x12

I/dalvikvm( 928): Could not find method android.appwidget.AppWidgetManager.bindAppWidgetIdIfAllowed, referenced from method com.android.launcher3.Launcher.a

  • What device are you using? – IAmTheSquidward Aug 14 '14 at 19:52
  • it is a rockchip 3066 based device and it runs arbitrary Apks(provided the dependencies are met) such as open intents file manager – Chromableed Studios Aug 18 '14 at 16:54
2

The manufacturer of this device doesn't claim that it's an Android device, and the error you're seeing indicates that standard parts of the API framework have been omitted. It looks like they're using a heavily cut-down version of AOSP. Unless you can find or port a full Android ROM to this device, you won't be able to get these apps working. You might have better luck with apps written for older Android versions which don't use so much of the framework: in particular, the missing function in this case was added in Android 4.1, so a launcher older than that might work.

  • I guess I'm looking at this as a step towards the rom process, I was really hoping for the direction as to WHICH api I might need to implement or find--more than what I already know that it's missing something – Chromableed Studios Aug 15 '14 at 17:51
  • That really changes the nature of your question. If you want help along those lines, you should edit your question to give the full details of what you're trying to achieve. Saying it "has a fairly customized launcher" really isn't enough information to start. – Dan Hulme Aug 15 '14 at 17:54
  • I don't think it really matters what the existing launcher is as much as what dependencies that ADW and or Launcher3 has right? I do indicate that I think I'm missing core libraries in the question, but maybe I should clarify – Chromableed Studios Aug 15 '14 at 18:02
  • Exactly. The launcher is a red herring: your question is really, "I have a device running a cut-down hacked Android, is there a way I can get real Android on it." – Dan Hulme Aug 15 '14 at 18:07
1

On xda someone has a set of tools/instructions to determine the dependencies:

http://forum.xda-developers.com/showthread.php?t=1476797

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.