6

I've been having issues with the Play Store's recent 4.9.13 update on my Blu Dash 4.5. Every time I try to install or update any app that is more than 1 MB, I keep getting an "insufficient storage" error, even though I have about 120MB on the apps partition free. Apps do install and update on an older version, however. In addition, the icons on the Play Store have weird black borders. I have searched all over the internet and I have yet to find a solution for either of these problems. Apparently, most devices affected by these bugs are using MediaTek chipsets and have Android 4.2 on them. My phone is using the stock ROM and is not rooted.

This is what it looks like when I enter the Play Store.  You can barely see a black border on the Ice Age Adventures icon.

A better look at the icons.

This app in question is about 2 MB.

  • Have you tried clearing the data for the Play Store app? – ale Aug 15 '14 at 0:46
  • You definitely got a more updated version of play store than what I have.. The version I have is 4.8.20.... How did you update the play store app??... One suggestion to... Can you do a force uninstall updates which is located on Settings>Apps><Swipe over to>ALL and select the Play Store. See if reverting back helps. And if so I'd say there is a pretty bad bug within that version. – Rushnosh Aug 15 '14 at 2:57
  • @Al E. Unfortunately, clearing the data does not help. – ctsao68 Aug 17 '14 at 13:21
  • @Rushnosh: I actually did uninstall the update a few times. I can confirm that it is a issue with the Play Store. Unfortunately, the update will reinstall regardless of settings. – ctsao68 Aug 17 '14 at 13:24
3

The correct answer to this problem, and I always see wrong explanations, is that you have a duplicate /data/app-lib folder for the app or apps that are giving you that error.

To fix: Using adb, terminal, or root explorer:

compare /data/app to /data/app-lib

you will see, for example:

  1. /data/app/example-app-1.apk

  2. /data/app-lib/example-app-1

  3. /data/app-lib/example-app-2 <--EXTRA

OR

  1. /data/app/example-app-2.apk

  2. /data/app-lib/example-app-1 <--EXTRA

  3. /data/app-lib/example-app-2

So for 1st example remove directory: /data/app-lib/example-app-2

and for 2nd example remove directory: /data/app-lib/example-app-1

Then your app will install just fine!

ALWAYS REMEMBER TO KEEP THE SAME NUMBERS,

IF THE APK IS 1 REMOVE 2... IF THE APK IS 2 REMOVE 1!

  • Won't this require root? – ale Aug 17 '14 at 14:02
  • Yes, that is the problem with this bug... I am just explaining what causes that insufficient space warning. For some reason, when apps update, sometimes Play Services does not remove the app-lib directory for that app. It happens to me quite a bit. And that is how to I fix it. – SudoSURoot Aug 17 '14 at 22:38
  • I don't think there is anyway to remove the folder without root. However until Google fixes the Bug, I would try to get the app's apk... asking for the app's apk online or if you already have it, I would suggest trying to install with adb, except use adb install -r application.apk the -r flag is reinstall. Check when Play Services was last updated and version, as it may be Play Services not Play Store causing the left behind app-lib folders. Then, I would get the apk for previous play services or play store and use it. That won't remove the app-lib folder but will prevent more. – SudoSURoot Aug 17 '14 at 22:38
  • @SudoSURoot So in a normal case we are looking at this scenario (using the nexus5 - hammerhead): root@hammerhead:/data/app # ls | grep -i vending com.android.vending-1.apk root@hammerhead:/data/app # ls ../app-lib | grep -i vending com.android.vending-1 @Crayon Will try out our play store update and see if I can replicate the issue myself. – Rushnosh Aug 17 '14 at 23:50
  • 1
    There is actually an app to fix this, which removes all extra /data/app-lib folders, but it needs root access. It is created by Jrummy apps, and the apk download is located at: jrummy-apps.com/faqs and click/look under section titled Google Play gives an 'Insufficient Storage Available' error – SudoSURoot Aug 18 '14 at 0:19
0

First of all this is a bug somewhere on play store side so I think we can only get a work around not an actual solution, said that I solved freeing more space than it would be theoretically needed, using old version of play store works too.

As for how much space is needed I don't have a clear answer because my phone (also on android 4.2.1 and MTK based) is rooted and I symlinked some apps to a different partition to be able to use more than 1.5GB as internal storage (that's data size partition in my phone). So I think this causes some problems on size estimation because Manage apps says I have 491MB free (correct) enter image description here

but Settings->Storage says I have 195MB Available (not correct). enter image description here

You can try removing some apps, I think 180MB free should do.

As for the black border I've had that problem since some months, I didn't dig much on the issue but I think they changed image format (new one is webp) and the transparency layer is not working well in our phones.

@Rushnosh

This version is out one month already but updates roll out not at the same time for everybody, if you want to try it you can update it manually downloading the apk from a trusted source like: http://www.androidpolice.com/2014/07/22/google-play-store-update-4-9-13-adds-material-design-app-and-content-pages-apk-download/

For images problem look here: https://productforums.google.com/forum/m/#!topic/nexus/tw1FebzJQng Looks like from Google the only answer is to ask manufacturer to update to KitKat.

  • @SudoSURoot I had that problem before, with something not being cleaned up, but it's not the current problem I am having with this play store version. I checked all possible duplicates that can be in: app-lib, app, dalvik-cache and I had none. The only two ways i was able to update was using an old version or freeing more space. The only key was app size and free space available. (can't comment in the other answer) – Crayon Aug 18 '14 at 8:58
  • It works for me buddy. However, you have to uninstall more depending on your storage capacity. For example, my capacity is 2GB and the minimum allowance or free space left required to download is 160MB. If it's below 160MB (memory or no. of installed apps) you get an "insufficient storage error." Even if you download 1MB app and installed it onto the storage with 159MB of free space left and it will not install it until you have to either free memory cache or uninstall app at lest 1 MB. – David Dimalanta Jan 27 '16 at 1:52
0

Just uninstall google play store update to revert back to the factory settings. Then updating apps will be possible.

-1

Solution for this issue is to move some apps to the phone storage or sd card and not in the internal storage; like you go to phone or mobile settings>apps>go through each app that you installed if there is a button that says "move to phone storage" or "move to sd card" click on it,in this way application will be moved out from internal storage because most of the times playstore identifies storage of apps are on internal storage not on the phone storage or sd card eventhough you have plenty of memory storage on your phone or card so that may be the reason why you have insufficient memory storage..

-1

Try uninstalling the updates to put Google Play Store back to factory version, disconnect your connection, then set "Do Not Update" in Play Store settings.

My problem is fixed but I have an old version of Google Play. But I can update my application.

  • I thought the "do not update" option only applied to any app on my phone that's not the Play Store? So far, the old version of the Play Store does work on my phone. The problem is that it will update itself to the newest version no matter what I do. – ctsao68 Aug 17 '14 at 13:33
-1

Download the apk for 4.8 from android police, decompile, change package name, compile, install. I don't think it would be able to update then. You'd have two play stores, keep the original and wait for an update that fixes it, but use the other one in the mean time. I hope this helps.

protected by Community Aug 29 '14 at 2:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.