2

This question already has an answer here:

tl;dr: What is the hidden setting that tells the first-time-user-wizard to run? i just want to re-enable that flag so next time the phone boots it shows the new user wizard and UI hints.

A friend gave me his new nexus to install CM11 and a few applications.

To install those applications i created a bogus Google account, downloaded them from the store, configured and then removed my account.

now i want to give the phone back in a way that when it is powered on, it shows the create new account/enable Wifi/etc wizard.

I already tried wiping out data from "one time setup" system application, but that did nothing. Any other ideas?

marked as duplicate by Firelord Dec 30 '18 at 6:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Are you looking to do a factory-reset? But that would also remove the apps you've installed. Apart from that: apps are always "bound" to the account you've installed them with (not speaking of multi-user here), especially payed ones. "wiping data" already removed what you configured anyway. – Izzy Aug 15 '14 at 20:01
  • i want to keep the ones configured on the phone. i added a bogus account, installed the apps, removed the account. – gcb Aug 15 '14 at 22:22
  • There might be a "hidden setting" somewhere (to indicate whether the wizard has run), but I never read about an "official way" to trigger that. If you want "pre-configured apps installed", there's no easy way doing that. While it could be achieved using adb backup or the Helium Backup app, I doubt that makes it easier for the "target user", neither would any other way of "side-loading" the apps. If an easy way to point to the apps is sufficient: AppBrain offers a feature to share "lists", which can be used to "install all on list" to other devices. – Izzy Aug 15 '14 at 23:50
  • Perhaps you could extract the APKs and put them inside a flashable ZIP, do a factory reset, then flash the ZIP? – aureljared Aug 16 '14 at 1:31
  • @Izzy that is exactly what i want here :) that hidden setting. – gcb Aug 16 '14 at 1:51
0

I had the opposite problem. I deleted OneTimeInit and SetupWizard and after a hard-reset my system was acting like in first time init screen:

  • notification pull-down is unavailable
  • recent screen is unavailable
  • home button is unavailable
  • limited power menu

So I had to set all those first boot flags manually. Then, I found three of them, which solved my problem:

settings put global setup_wizard_has_run 1
settings put global device_provisioned 1
settings put secure user_setup_complete 1
-2

did not find the solution. but found the 'good enough workaround'

  1. delete all wifi you have saved
  2. charge battery to maximum
  3. remove account used to install everything
  4. clear recent app history
  5. delete the home screen app data.
  6. open the new account setting
  7. lock phone.
  8. ship it
  9. hope it arrives in less than 3 days which is what it took here to drain the battery :D

now when the phone is taken out of the box, it will have (almost) the same as the welcome screens as the phone is factory reseted, but will keep the apps installed. It will prompt for new/existing account, pair with wifi, and show all the home screen apps hints.

and i was spared the work of adding a few extra apps to the cyanogemMOD image and ship the phone 'factory' reseted. much easier that way :D

  • Be aware that many carriers/postal services won't let you ship charged batteries because of the fire risk. Be careful to check as it may be a criminal offence (if using a postal service or air freight). – Dan Hulme Feb 17 '16 at 17:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.