1

Android 4.2.2 update fails on my Alcatel One Touch Idol S . The hardware is hardly the issue since it worked smoothly on my wife's phone which is exactly the same model.

Specifically, Android installed version is 4.2.2/01001 . The update has the exactly same version number (but there are real differences after the update on my wife's phone, new features).

I did nothing specific before attempting to upgrade besides installing applications, the phone is not rooted.

I can download the update. When I press the install button, my phone restarts, but after a few seconds I got the message

Finding update package ...
Installation aborted
Error !

with a picture of a broken android and on the top

Android system recovery

with the following choices

  • reboot system now
  • apply update from ADB
  • wipe data /factory reset
  • wipe cache partition
  • apply update from storage
  • fota status operation

What shall I do? I tried wipe cache partition, with no success. The only difference I can see with my wife's phone is that mine is equipped with a micro sd card.

p.s.: I have seen Update to Android 4.0.4 fails but this is not a duplicate.

  • are you sure its the same hardware on both phones since you said you have SD Card and the other phone dont. check the Version number. – Itzik Samara Aug 17 '14 at 10:37
  • yes I am 100% sure it is the same hardware, simply on one phone we did not add a SD card and on the other we did. – Niels Aug 17 '14 at 12:36
  • ok if you remove the SD Card does it work? – Itzik Samara Aug 17 '14 at 12:51
  • I tried without SD Card , it doesn't, unfortunately. One other difference is encryption, my phone is encrypted, could this be the issue ? – Niels Aug 17 '14 at 12:54
  • Encrypted means have you set any password for SD card? – MANI Aug 27 '14 at 3:57
2

If you don't mind factory reset/wipe the phone and try updating again (back-up data before doing so). It should do the trick. But before trying above method, also try this because I doubt that the device is lacking memory resources on both SD card & internal memory. Try to make some free space in internal memory/external memory (400 MB-500 MB must be suffice).

2

Going by the error message which the device is giving conveys that the Android update has crashed midway. This crash during the update is possible due to loss of network connection or the device booted during the update.

As the update has crashed you will not be able to update your phone even if your place an SD card or not because the Operating System of ay android version irrespective of the hardware is always installed on your on board storage space but not on the SD card.

The only possible solution for your crashed update is

First you need to do a factory reset. Doing a factory reset will completely wipe our memory and will retain your device as it was in the start when you purchased it.

Before going ahead with the factory reset please be sure that you are ready to wipe your data and have a Backup present with you.

After doing the reset make sure your device is completely charged and have a Good connection to the internet. If you do not have any one of the above then you could again face the same issue and to the max may not be able to use the device in severe cases.

Once both are achieved you should be able to easily update your device

1

Have you tried doing the update from your PC instead? You can download the Mobile Upgrade software and connect your device to your PC to perform the update.

Launch the tool and update your phone by following the step by step instructions (refer to the User Guide provided together with the tool). Your phone’s software will now have the latest software.

Note that this will wipe your device according to the user manual which also recommends using the One Touch Center software to backup/restore your personal information

All personal information will be permanently lost following the update process. We recommend you backup your personal data using ONE TOUCH Center before upgrading.

  • Thanks for the help - I had the same idea, and tried, but this fails as well. – Niels Sep 2 '14 at 19:32
0

It may be a firmware upgrade(firware over the air fota). There is a fota app. Go to apps in Settings. Click on clear data for fota app. Check for update again.

0

Your update package has expired. You need to root your Android device (you can root it with Kingo Android ROOT). Then, you can flash a custom ROM with your PC with Smart Phone Flash Tool

You will also need:

  1. Kingo Android ROOT (this is a PC software)
  2. ADB driver installer (PC software)
  3. Custom ROM (I recommend KitKat 4.4.4 or Lollipop 5.0)

These all software are free and support all PCs

  • 1
    How did you get an "update package has expired" from " >Finding update package ... >Installation aborted > Error !"?? – HasH_BrowN Nov 21 '14 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.