0

Yesterday my noble Galaxy Nexus (maguro) sacrificed itself to save me when I fell from my mountain bike.

I would like to copy the data to my computer. What is good: the screen and the sim card is broken, but the rest of the phone seems to be still working.

When I plug in the phone on my Linux (Debian) computer, it is detected as multimedia device. However, I cannot access the data, as I would need to unlock the screen (which is broken).

Alternatively, I tried to access the phone using the adb-tools. However, the device is not listed:

$ ./adb devices
List of devices attached 

$

I can see my phone in lsusb:

$ lsusb
...
Bus 006 Device 002: ID 04e8:685c Samsung Electronics Co., Ltd GT-I9250 Phone [Galaxy Nexus]
...

I tried some different stuff, like generating a /etc/udev/rules.d/51-android.rules file, but this didn't help.

I also tried to boot the phone to the bootloader, but I didn't succeed - maybe the connection to the volume buttons is broken.

Some additional information that may help: my Galaxy Nexus runs AOKP and Clockworkmod is installed.

  • Do you remember if you had USB Debugging enabled? Without it, ADB won't work. Also, look here for help enabling it: android.stackexchange.com/questions/12834/… – IAmTheSquidward Aug 18 '14 at 17:29
  • I think yes, but I don't know exactly... Is there a different way if it's not enabled? – speendo Aug 18 '14 at 17:31
  • Have you tried booting to recovery (or do you mean that by "bootloader")? As you're running a custom ROM, you certainly have a custom recovery installed. Those often (usually? always?) have debugging enabled by default. You might need to mount the partitions you want to recover data from manually then, though. – Izzy Sep 3 '14 at 14:11
  • I tried to boot into recovery (yes, that's what I mean with booloader). However, it seems the volume rocker is broken as well so I can at least not confirm that the phone was booting to recovery. But it should be possible to overcome the issue of the broken volume rocker, so I'm quite confident that I will manage to boot to recovery. – speendo Sep 3 '14 at 14:49
0

As your device is rooted I assume you can download nexus root toolkit to pull and push files, it automatically handles both, bootloader booting and fastboot, through adb, if however you didn't have usb debugging enabled I cant help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.