1

I'm quite sure this is hardware problem. I tried the following:

  • cleared application cache and restarted phone
  • tried alternative camera applications
  • reset phone to factory settings (still doesn't work)

There is just error message saying:

Unfortunately, Gallery has stopped.

Now I suspect it could be Gallery app problem. I rooted the phone and used super user app to disable Gallery and than install alternative gallery app. Still not working, now error is

Camera has stopped working

Is there any way I can check if actual camera is broken? I'm using Android 4.2.2 on the Doogee DG130?

Log file ( part about camera ): https://drive.google.com/file/d/0B0-PZcQ_Q9-ZV1pON0ZlMzNjck0/edit?usp=sharing

Here is the exception stack trace from the logcat

08-19 17:03:08.098 W/dalvikvm(18229): threadid=14: thread exiting with uncaught exception (group=0x414369a8)
08-19 17:03:08.098 D/IPCThreadState(18229): [DN #5] BR_CLEAR_DEATH_NOTIFICATION_DONE cookie 0x50840260
08-19 17:03:08.100 E/AndroidRuntime(18229): FATAL EXCEPTION: Camera Handler Thread
08-19 17:03:08.100 E/AndroidRuntime(18229): java.lang.RuntimeException: startPreview failed
08-19 17:03:08.100 E/AndroidRuntime(18229):     at android.hardware.Camera.startPreview(Native Method)
08-19 17:03:08.100 E/AndroidRuntime(18229):     at com.mediatek.camera.AndroidCamera.startPreview(AndroidCamera.java:168)
08-19 17:03:08.100 E/AndroidRuntime(18229):     at com.android.camera.CameraManager$CameraHandler.handleMessage(CameraManager.java:168)
08-19 17:03:08.100 E/AndroidRuntime(18229):     at android.os.Handler.dispatchMessage(Handler.java:107)
08-19 17:03:08.100 E/AndroidRuntime(18229):     at android.os.Looper.loop(Looper.java:194)
08-19 17:03:08.100 E/AndroidRuntime(18229):     at android.os.HandlerThread.run(HandlerThread.java:60)

And this is entire log for last 2 minutes ( while I was opening a camera ): https://docs.google.com/file/d/0B0-PZcQ_Q9-ZTW9QeTVKdk1NdEU/edit?pli=1

  • Provide output of logcat command – RRD Aug 19 '14 at 13:06
  • It's probably the Gallery, it is very tightly linked to the camera in stock Android. Try re-enabling it. Alternatively try installing another camera from the market, but NOT a Google one for obvious reasons. See if that works. – RossC Aug 19 '14 at 14:24
  • @RossC thanks I will try, I used an app to disable gallery only, I didnt actually remove it completely. When enabled I get gallery error, without it I just get camera error – Roxxy Aug 19 '14 at 14:35
  • Your nuclear option is to flash a new ROM or a backup. But obviously don't do that first. Try re-enabling, rebooting, re-installing apps etc as you go. Try to narrow it down. What is the Gallery error? – RossC Aug 19 '14 at 15:04
  • just says Unfortunately, Gallery has stopped. I updated log now, there seems to be errors like: FATAL EXCEPTION: Camera Handler Thread 08-19 17:03:08.100 E/AndroidRuntime(18229): java.lang.RuntimeException: startPreview failed but I still cant tell what could be the problem – Roxxy Aug 19 '14 at 15:21
1

Check out this application to know whether it has Camera/Hardware problem - System Info Droid
It provides whole summary of the device.

protected by Community Apr 5 '16 at 20:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.