0

In my university, I have a free internet WiFi access with eduroam system. However (double-checked the login and password already) I can not connect to the network with my phone :(

All the security parameters are fine (my Asus laptop connects with no problem).

When I had a Samsung phone, I was able to connect. I had to sell it, and now ended up with Prestigio. However, I can connect with other WiFi networks around using my phone. What might be the problem here?

3

This is something you should ask the IT support people at your university about. Most mysterious problems like this are caused by security settings on the Wi-Fi network itself. Probably it is MAC-filtered, so only devices that have been registered with the network administrators are able to connect. You might have forgotten registering your previous phone if you've had it for a long time.

  • I threw out this phone a long time ago, it was a piece of garbage. But thank you anyway :) – Brian Brown Jun 23 '17 at 17:58
2

It is possible that your device doesn't support the encryption and authentication methods that eduroam uses. While normal WPA2 encrypted WiFis use TKIP encryption, eduroam uses AES. In addition to this, the device must support Enterprise authentication (sometimes called 802.1X), and a compatible EAP method (EAP TTLS-PAP, PEAP, EAP TLS EAP FAST). Which of these is used is up to your network administrator.

Like the other answers said, try asking your network admins for help.

1

Well, that's weird I would say if the device is working with the other Wi-Fi network then have you tried talking with the Network Administrators? Sometimes they block mac address to prevent misuse ! I would say this problem can only be solved from the network admins. Try talking to them about the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.