my HTC Wildfire with CM7 - RC4, doesn't like a combination of two things:

  • Data enabled on a 2G Network
  • SD Card inserted.

When these two conditions are met, either the phone will slow down to a halt or it will reboot. If it reboots, if I don't remove the SD card it will not detect it, unless I reboot without it in. Or, the SD card will just be undetected and sometimes a notifications pops up telling me "SD Card Removed Unexpectedly"

At my school, my phone network's signal isn't very good due to the building being rubbish and 2G signals are the only thing we get inside the building.

On my old SD card it was 4GB and I think it worked, however my SD card is now 16GB and it doesn't like this. It shouldn't be a problem as it's a ScanDisk (a very reputable make) and I've tried another 16GB card which I sent back due to the issue, so I don't think it's that.

Many thanks to people who can figure out what's up with my phone,


  • This is bizarre! – Matthew Read Apr 9 '11 at 15:37
  • Yeah, I thought it was myself, however it happens 100% of the time. – Joe Simpson Apr 9 '11 at 15:44
  • what apps are installed in the phone? Probably there is a bug in an installed app or networking/filesystem drivers. Are you using app2sd? Does this happen on stock ROM? – Lie Ryan Apr 26 '11 at 5:00
  • I'm not using apps2sd. I never had a 16gb SD card before I rooted and the problem is still there on sense based wildpuzzle rom. – Joe Simpson Apr 26 '11 at 11:09

I would indeed verify first that this is not related to some 3rd party app or any other than stock ROM. For this do a complete reset and try again. Also try with a smaller SD card since 16GB might not be supported by your phone (need to check specs for that, I don't know).

You can make a backup to get it back to your personalized settings quick.

If you can confirm the stock ROM and default settings do have this bug too you can report this to HTC. Otherwise you'll have to solve it on your own, looking what app/setting is getting this result.

  • Hmm.... Well HTC do say on their website, "Supports up to 32 GB" which is confusing – Joe Simpson Apr 29 '11 at 13:51

Scandisk? you sure? Did you mean SanDisk?

Can you absolutely vouch for the authenticity of the SD card? There are plenty of 'fakes' - usually low grade/slow branded as faster cards.

Theres a good guide to spotting fakes here eBay guide

  • I bought it from Amazon themselves, so I doubt they would be selling fakes :/ – Joe Simpson Apr 29 '11 at 13:52

I had exactly the same issue here, on my Asus fonepad tablet. It happened from the beginning, with few 3rd party apps installed and different SD cards.

My workaround was to set "WCDMA only" in the settings ;)

  • @Izzy He provided a workaround. So, I suppose that counts as something helpful. :) – geffchang Aug 7 '13 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.