5

I have already read this and this but can't stop the automatic blackground update.

I currently use Samsung grand 2 dual (SM-G7102) android 4.3 and cellular mode.

I'm setting-->usage “Restrict Background data” but the android OS is still running the updates in the background.(see picture) help me please.

enter image description here

Click image(s) for larger version

I'm setting “Restrict Background data” in 24/08/2557 but On 25/08/2557, "Android OS" was still sending out to cellular.

enter image description here

Click image(s) for larger version

I'm allow Facebook, Line and Messager can use cellular but don't want the "Android OS" Update. The mobile is rooted

The "android os" was “Restrict Background data”. Help me please.

  • your 2nd screen shot is not clear from what you want. Could you please update your screen shot without the notification bar sliding down and add another screen shot for the options that are enabled in the shortcut bar. – user285oo6 Aug 27 '14 at 5:44
  • 1
    Put Auto-Sync in Settings to off. – MANI Aug 27 '14 at 6:30
  • update picture and detail. – ohno Aug 29 '14 at 2:58
  • This appears to be a similar question to android.stackexchange.com/questions/58620/… Thanks for the hints from other answers. This is an indirect answer but while on mobile Internet I used Mobiwol firewall without rooting to block "Android OS" background data. It appears to work on Galaxy S5. – f01 Nov 15 '14 at 18:37
  • @ohno Did you try under the Update>select update only via WiFi,Play Store>Update apps only via WiFi as checked – user285oo6 Dec 23 '14 at 7:43
2

This is due to Google Backup.Switch Google Backup off and your problem will be solved. Follow these steps:

  1. Open Photos app.
  2. From options goto Settings.
  3. Touch Auto Backup and switch the toggle On or Off.
2

You need to install a "Root Firewall" in your mobile by which you can control the Internet connectivity of all apps (including system apps). They also offer to block only Data connection and not wifi connection for a specific app.

The app I'm using is "AFWall+" (free).

Note: This type of apps only works on Rooted android phones. Here is the greate article about rooting in android. It is highly recommended for you to know everything about rooting before choosing this option.

If you have decided to go along with AFWall+ and you understand the risk of rooting your mobile device then visit this link to configure your AFwall+ for the first time use.

Further check this answer by @firelord for step by step configuration and screenshots of AFWall+.

If you need further help and have a question related to this answer please comment. I'll be happy to help you.

  • @Firelord thank you for your suggestion. I have edited my answer. – Muhammad Saqib Jul 31 '15 at 11:03
  • +1 for the official FAQ among other things. In case somebody need screenshots, try my answer here. – Firelord Jul 31 '15 at 11:07
0

All other things are also helpful like disabling Auto Sync Background data, etc. Try doing this:

  • Go to Settings -> Apps -> All Apps.
  • Go to the last app Update Centre and then tap on it.
  • After opening it tap on Force close.

I think is is the probable cause of the background data usage by Android OS. And by doing this you may get rid of it.

Note: You need to remember that you will have to do this trick every time you restart the device. If you have a pending System Update, then its icon from the notification tray will disappear. This directly means that your device will no longer search for System Updates until you restart it.

In short, to stop OS using mobile data, force stop Update app.

  • Its not u but you. Please refrain from using the former. – Firelord Apr 27 '15 at 2:01
-1

If you agree then try to use developer options. By using this option when you leave or minimize your app with home button or anything other, your app activity automatically stop. It shows only activity view on task manager but displays activity as not working.

Go to settings -> find Developer option. Tap seven time on developer option and new Developer window will open. Now find "Do not keep activity". If it is not marked, then mark it. By default it will be not marked. Now try to open any app activity and minimize. Then try to restart activity from recent task and see magic. It will not start. It means it stoped.When you want to disable this from working then simple switch off your developer option.

-2

Its much easier bro! Just go to settings-->data usage-->click on the 3 vertical boxes in right top cornet--->Tick on restrict background data---->then remove tick in auto sync data

Thats it bro....

protected by Community Aug 11 '15 at 14:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.