2

I've spent the last 15 or 30 minutes trying to login to the Gmail app and the Play Store on an ASUS TF-101 tablet. During the same time, I've visited a desktop computer, logged out, re-entered the username and password, and logged back in just fine.

Here's a cropped image after attempting to login to Play Store. I'm certain the username and password are correct from testing on the desktop:

enter image description here

The tablet has internet connectivity, and the time is set correctly. I even performed a factory reset and the problem still persists.

A few questions:

  • Any ideas why I've wasted 1/2 hour trying to login using this tablet?

  • How do I login into Gmail App and Play Store using Gmail credentials on an ASUS TF-101 tablet?

  • Why am I being forced to use a password mask created for a 1960s teletype terminal in 2014? I certify that no one is standing behind me.

  • How do I remove the password mask so I can actually see what's being entered?

Related: I found a similar issue at Can't log in via Gmail app but browser login is fine, but the time is set correctly and there are no other helpful answers.

  • Does the username include @gmail.com? – geffchang Aug 28 '14 at 12:16
  • @ geffchang - Yes, I've tried with and without the domain suffix. – jww Aug 28 '14 at 16:20
  • Like this answer mentions, do you use two-factor auth? Might want to turn that off and try again. – gary Nov 16 '14 at 17:16
4

Did u set 2 step verification to your Gmail account? If yes then you need to set Application Specific Password to your account.

  1. Login to your Gmail from Desktop.
  2. Goto Settings page.
  3. Find Authorizing Application & sites page.
  4. Goto Application Specific Password section
  5. Set your app name and device and Password, then click Ok.
  6. Now you can login to your app with that new Application Specific Password.

For more help visit this page.

https://support.google.com/mail/answer/1173270?hl=en

2

As a workaround for not seeing the password, you could type your login name and password into an app that uses plain text, like a notebook or even an email. Then copy each, one at a time, and paste them into the name and password field for the login. It seems like I've seen an option to show passwords somewhere, but I enabled that, and I still don't see passwords, so I have no idea what that does.

If you still can't log in, then perhaps the server is not set to what you think it is for some reason. That's a long shot, considering the facts as you posted, but it's a possibility, I guess.

One more thing... you don't use two-step verification, do you? I had a lot of little problems with using that along the way, including not being able to log in to a few apps that didn't handle it correctly. And gmail requires a different password if you use it, for some reason.

1

Go to Security in Settings and check Make passwords visible so that you can see what you are typing actually.

  • +1. One of my questions was "How do I remove the password mask so I can actually see what's being entered?" – jww Feb 24 '15 at 21:49
1

I had a similar problem with another Android tablet. 2 step verification was turned on, but after typing correct password and code, I got a similar screen to the original post.

Google help was unhelpful but I managed to solve it by attempting to apply an app password. [Note that in this fix, for me, I did not in fact need to set an app password].

At one stage, in a seemingly Catch-22 style situation, I got asked for my password and a code as per standard 2-step verification, but this time it all worked and my tablet signed into my Google account. Fixed!

An inelegant but effective solution! Unfortunately I cannot seem to recreate the process, and I do not want to risk not being able to sign in again, so I cannot give detailed steps to follow.

Keywords: "app password"

  • Update: Tablet again failing to sign in, so the above did not work long term. Fixed by removing Google account and adding account again. – user85047 Dec 15 '14 at 23:32
0

I had a similar problem, until I found out that the touchscreen was messed up, and was typing a certain letter twice, so try typing your password in the username field and see if it's typing it right, just to make sure.

0

It appears Google Play and Gmail wanted an Application-Specific Password.

I can only say "appears" because I never got a message that remotely stated it, and when I created on the problem went away.

Great job Google. I can't image how many hundreds or thousands of hours have been wasted because Google can't be bothered to get the error message correct.

  • 1
    So you are using two-factor auth? In this case the usual login form won't work; however, when adding a Google account, there should be a “Login in browser” option hidden under the Menu button (three dots), and that option works with 2-factor auth. – Sergey Vlasov Aug 29 '14 at 11:24

protected by Community Feb 24 '15 at 20:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.