3

My WhatsApp icon has recently disappeared from my phone completely. It's neither on the home screen, nor the main menu. When I go to the Google Play store, it shows that it's part of my installed applications. I uninstalled and re-installed the app, but it still doesn't show the main icon, so I'm unable to even open it... Even though it says it's installed on my Samsung Galaxy S2.

  • if the app is shown as installed..there will be a Open button in google play to open the app..have u tried that..or if you use any app hiding laucher or any third party apps release the whatsapp and unhide it.. – Lucky Feb 7 '15 at 7:41
  • Samsung will put WhatsApp icon in the "Social" folder. Check also there. – Paolo Dec 18 '15 at 17:23
1

Things I would try:

a) Just reset the phone if you haven't done already(turn it off and on

b) Uninstall the app, remove the sd, and install it again. There might be a problem with your SD card, and if the app is automatically installed there, maybe that's the reason you can't see it

Which launcher are you using? I believe you can see the app in the settings -> applications list?

| improve this answer | |
1

Go to settings --> apps-->on the top right corner, click on three dots and choose protected apps. Now you should see all installed apps and only the one's which are installed and missing will have a tick mark next to it. Uncheck and reboot. You should see the missing apps icon .

| improve this answer | |
0

Perhaps its just hidden. Click menu 》unhide

| improve this answer | |
  • If it's been uninstalled and reinstalled it isn't hidden – Beta Decay Aug 30 '14 at 9:39
0

By removing and installing again the battery I solved the problem. The icon reappeared immediately after doing so.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.