-2

My Nexus 4 suddenly went into bootloop today after getting drained last night. I tried booting into recovery mode, but as it is not rooted or unlocked, fastboot and adb sideload do not work. I want to recover my data, is it possible?

What should I do? Please help!

  • Have you checked with our boot-loop tag-wiki for first aid? Did that help? – Izzy Sep 2 '14 at 11:42
  • I have cleaned up the comments here again and on the answer. Use this comment space for relevant clarifications and such only. – Matthew Read Sep 4 '14 at 19:33
  • @MatthewRead It seems you have also deleted legit discussion on the answer below and that too selectively. – Sumit Jain Sep 5 '14 at 5:54
  • I tried to summarize. – Matthew Read Sep 5 '14 at 7:24
1

This would be the toolkit needed to help alleviate your bootloop. Read the whole thread to fully understand what is going on.

http://forum.xda-developers.com/nexus-4/orig-development/toolkit-wugs-nexus-root-toolkit-v1-8-2-t2015469

You'll be able to root your device, fix your problem, then if wanted you can relock your device or install a custom ROM. I used this on my Nexus 7, when I accidentally wiped everything (turned it into a paper weight). There were other ways to fix, but the toolkit is by far the easiest.

Hope this helps and Good Luck!

  • how can I take a backup without unlocking the bootloader(and with that wiping my data)? – Sumit Jain Sep 3 '14 at 6:26
  • @SumitJain Unlocking the bootloader or installing a ROM will erase data, but rooting shouldnt erase/wipe anything. For doing a backup before unlocking bootloader through adb use this cmd: adb backup –apk –shared –all –f /<location of backup.ab> Then to restore use this cmd: adb restore /<location of backup.ab>. Those cmds were pulled from this link: android.stackexchange.com/questions/44574/… – HasH_BrowN Sep 3 '14 at 6:38
  • Also take a look at this link. forum.xda-developers.com/showthread.php?t=2588979 You might have to read it twice. It's a lot of info, but you'll have working knowledge of adb and fastboot. BTW, the toolkit should have had adb and fastboot as part of the program. If not, then download from the link I provided. reflash boot.img(kernel) from FASTBOOT. That won't erase anything. Power the Nexus up into the boot loader, select fast boot, hook it to the PC, enter the commands. You don't need to be rooted or boot loader unlocked to use FASTBOOT. – HasH_BrowN Sep 3 '14 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.