0

After an update I cannot use my settings app it gives an error unfortunately settings app stoped working so reset my phone and now I cant do anything any help on allowing apps from unknown sources without settings app or enable usb debugging without setting any thing will help

  • 2
    Although you can't replace the settings app, we might be able to help you fix it if you edit the question to describe your problem in more detail. What kind of update triggered it? What have you already tried? When do you get the error? What phone do you have? – Dan Hulme Aug 30 '14 at 20:05
  • Alcatel ot fierce it was an update from t mobile I got this error like a week ago I haven't tried anything but reset – kevin Aug 30 '14 at 20:09
  • Try booting into recovery mode. There, chose "Wipe Cache" (and yes, that's possible without root or custom recovery). With a custom recovery, you could additionally "Wipe Dalvik Cache". Sometimes cache gets screwed up and causes trouble like that, wouldn't be the first time wiping it solved the issue. // Ooops, crossed your post. If you already tried a factory reset, cache wiping wouldn't help either as it's part of it :( – Izzy Aug 30 '14 at 20:10
0

There's no other way to change the "unknown sources" setting, but if you root the phone you can find apps to toggle USB debugging simply by searching on Google Play.

There's no way to replace the settings app without replacing the whole ROM. The settings app is just too closely tied to the rest of the system: it's not designed to be replaced.

  • I canot currently root my phone cause usb debuggins is not enabled – kevin Aug 30 '14 at 20:20
0

It might be a wise idea to do a backup, and reinstall your ROM. It sounds like you somehow or other got the settings app switched from a system app to a user app. Without debugging enabled, it will be a slight hassle, but this is fixable.

Type in terminal emulator app:

am start -a android.intent.action.MAIN -n com.android.settings/.DevelopmentSettings

To get debugging to work. From there you run a log cat, and see what's holding the settings app from running correctly

This should work w/o root

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.