0

After an update from T-Mobile to my alcatel Fierce, I cannot use my Settings app. It gives an error "Unfortunately, Settings app stopped working", so I reset my phone and now I can't do anything.

Any help on allowing apps from unknown sources or enabling USB debugging without the Settings app?

1
  • Try booting into recovery mode. There, chose "Wipe Cache" (and yes, that's possible without root or custom recovery). With a custom recovery, you could additionally "Wipe Dalvik Cache". Sometimes cache gets screwed up and causes trouble like that, wouldn't be the first time wiping it solved the issue. // Ooops, crossed your post. If you already tried a factory reset, cache wiping wouldn't help either as it's part of it :(
    – Izzy
    Aug 30 '14 at 20:10
0

There's no other way to change the "unknown sources" setting, but if you root the phone you can find apps to toggle USB debugging simply by searching on Google Play.

There's no way to replace the settings app without replacing the whole ROM. The settings app is just too closely tied to the rest of the system: it's not designed to be replaced.

1
  • I canot currently root my phone cause usb debuggins is not enabled
    – kevin
    Aug 30 '14 at 20:20
0

It might be a wise idea to do a backup and reinstall your ROM. It sounds like you somehow or another got the Settings app switched from a system app to a user app. Without debugging enabled, it will be a slight hassle, but this is fixable.

Type in Terminal emulator app:

am start -a android.intent.action.MAIN -n com.android.settings/.DevelopmentSettings

To get debugging to work. From there you run a logcat, and see what's holding the Settings app from running correctly

This should work without root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.