I want to install Android in a VM to restore a backup using Titanium Backup. For this to work I need Android to be rooted.

What I tried

I've tried to install Android-X86 4.3 in a Virtualbox VM. The installation seems to work. I made a 8GB partition disk (sda1), made it bootable, and installed Android in it from an ISO file. This all seems to work. Android starts, I can browse the internet, install apps, etc. Then I want to restart the VM, and guess what?! I go back to the installation screen, like starting up from the ISO live image.

For normal stuff I can make a snapshot, start that up, and do anything. My problem is that I need root permission to restore a Titanium Backup in that VM. And I cannot root this VM because the disk is not writeable. With ALT-F1 I become root, and I can use a script to root Android. But my guess is that I'm still on the ISO and that is not writeable.

Update - another try with Android 4.2

As mentioned in the comments, 4.3 would have problems with root access. I tried 4.4, which didn't start at all. Then I tried 4.2, which has the same problem as 4.3 for me. I made a screenshot of what I see when I try to run the rootscript, which is described here.

You can see the errors: rm failed - Read only filesystem

How can I fix this?

enter image description here

My question

How can I install Android permanently on this VM, so it can reboot and then be rooted?

  • If you're talking about Android-x86 in VirtualBox: It usually comes with root access. Except for the 4.3 image, which I also failed to get root access on. You might wish to try a different image then.
    – Izzy
    Commented Aug 31, 2014 at 15:29
  • I'm going to try 4.4. It does come with root access, but that only works for the terminal via ALT-F1. It does not mean that the apps can use root access.
    – SPRBRN
    Commented Aug 31, 2014 at 16:49
  • I've got 4.0 (ICS) running in a VM. It has /system/xbin/su as well as /system/app/Superuser.apk, the latter being for the apps part. Never checked 4.4, but doesn't it have these as well?
    – Izzy
    Commented Aug 31, 2014 at 16:55
  • I can't get 4.4 to start up. So I'll give 4.2 a try and hope that works.
    – SPRBRN
    Commented Aug 31, 2014 at 18:57
  • Aside from the rooting, why can't I reboot after installing? Why does it seem like I go back to the live image? Do I miss a step somehow?
    – SPRBRN
    Commented Aug 31, 2014 at 19:06

2 Answers 2


For your reboot problem, it sounds like your boot order is booting off the .iso, i.e., cdrom, before it looks for the disk partition where you installed Android. Shut everything down and disconnect the .iso. You can just delete the CD device under the controller within VirtualBox Settings->Storage. You probably shouldn't just change the boot order or you will have trouble reinstalling if you ever need to. However, if you want to change the order, look under Settings->System->Motherboard.


If You set /system as read-write you don't will have any problems at all. In The Instalation do this :enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .