1

Right, so I've been an absolute idiot and I uninstalled mediatek-res.apk. I was probably very tired and I was stupid enough to forget to make a backup in recovery. The phone is a Chinese clone (Jiake JK3) and I can't find any stock firmware on the internet. It's now stuck in bootloop, so somehow I need to restore mediatek-res.apk. I can get adb access with root when I'm in recovery. I've tried pushing it to /system/framework with the correct permissions, but that hasn't worked. The log (when I boot up) says:

D/PackageManager( 1699): scan package: /system/framework/mediatek-res.apk , start at: 66650ms.

D/asset   ( 1699): AssetManager-->addDefaultAssets CIP path not exsit!

and

I/PackageManager( 1699): /system/framework/mediatek-res.apk changed; collecting certs

D/dalvikvm( 1699): GC_CONCURRENT freed 1976K (15855), 34% free 4069K/6124K, paused 1ms+2ms, total 19ms

and

E/PackageManager( 1699): Package com.mediatek has no signatures that match those in shared user android.uid.system; ignoring!

W/PackageManager( 1699): Signature mismatch for shared user : SharedUserSetting{41de1470 android.uid.system/1000}

I have no idea what any of this means but I'm a fairly capable user so if someone could let me know what it means that'd be great.

1

The signature mismatch indicates that the package you've installed (the mediatek-res.apk) isn't from the same source as the rest of the OS. It's from a different ROM, probably one made for a different device, by a different OEM. You need to find the APK file that matches the rest of your ROM, from the same device as yours.

  • Would turning off Signature Verification in the Recovery make any difference at all? If the OP has the ROM zip on their device/PC then they could pull out the apk probably anyway. Or dirty flash the ROM over itself..? Also worth noting: ALWAYS ALWAYS make a nandroid backup before deleting anything from /system or flashing zip files at all! – RossC Sep 1 '14 at 12:11
  • 2
    I don't think so, as it's not the recovery that's checking the signature, it's Android itself. – Dan Hulme Sep 1 '14 at 12:21
  • Yeah, the problem is with the Android bootloader. I might have managed to recover the original APK, because when I tried a new apk it boots to the lock screen and works for a second, then displays a force close message for Google Play Services and reboots. I've been trying to contact other people with the device from various Android forums so they can upload their firmware. – user2350334 Sep 2 '14 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.