5

I'm using Samsung Galaxy Ace GT-S5830. More than an hour ago, Samsung-Kies prompted me to install a firmware update. It downloaded the required files and then proceeded to the actual upgrade. Now, since an hour, I'm getting 0% progress on the "Firware update in progress..." screen. It obviously says not to disconnect the phone. The phone shows "Downloading..." It's been like this since an hour. I don't want to brick my phone by pulling the USB cable off. Please suggest something.

3 Answers 3

5

I would suggest pulling it off and trying again. Usually this happens when Kies wasn't able to properly communicate with the device after putting it into Download Mode. I've had this happen before and rebooting my device and trying again worked. You can also try putting the phone into Download Mode manually (may or may not work while plugged into USB):

  1. Remove the battery
  2. Hold VolumeDown plus the Home key plus Power. While holding,
    1. Reinsert the battery.
    2. Release the Power button, still holding the others, about 1 second after the white logo text appears.
    3. After a few seconds a yellow triangle with an android in it should appear, this is Download Mode. If it doesn't, try this again while holding Power the whole time.
3
  • Thanks, Mat! Pulled it off and the phone started normally. Will try it again tomorrow, gotta go.
    – user4292
    Apr 11, 2011 at 20:33
  • @Karan Did this work for you? Sep 9, 2011 at 16:58
  • It works for me.
    – krocan
    Nov 25, 2011 at 14:19
1

I know this sounds silly but press the power button ten times and walla! I read a YouTube comment after an hour of researching trying to find a solution and I tried it even thinking it was just a joke and I can't believe it actually worked !

2
  • does not work with Android 6, atleast on LG G4
    – allanlaal
    Jun 4, 2018 at 23:05
  • worked for me with Nexus 5, Android 8
    – story645
    Jan 22, 2021 at 5:58
0

I had this issue and took my battery, sim card, and memory card out for about two hours. When I put it back together, it booted right up and is working fine now.

You must log in to answer this question.