I bought my Android phone a month ago (a Prestigio 3350 Duo) and installed maybe 5 apps on it, so according to the memory card I have almost 2 gb of free space, and 28 mb on internal storage. But when I try to install some apps it keeps showing off that message.

I don't know why, tried to clear cache (which helped a little) – but still I can't install an app of about 34 mb.

Can someone help me fix this problem? I know there're similar posts but I appreciate any help. Thanks :)

  • 2
    Welcome to the Android Enthusiasts! This happens to be a question frequently asked on our site. Have you tried our on-site search? See How do I search? for help using it. Moreover: As it is that frequent, we've even summed up background and solutions in our insufficient-memory tag-wiki, which you might wish to consult. I'm pretty sure that will get you started. Good luck! – Izzy Sep 3 '14 at 19:00

It has worked on Kitkat so may apply to older versions of Android

  1. Settings > Storage > Phone Storage ( or could be Internal storage, wherever Google Play Services is) > apps > Google Play Services > Click Clear cache
  2. (on the same page) Manage space > Clear all data > Manage search storage > clear now
  3. press back button <- twice and you will end up on Google Play Services - App info page > press Force stop
  4. Find Google Settings among applications or under Settings > Google settings > click on menu button on the page > Clear app data

Now you can launch Google play store and download desired application

Hopefully it works for you as well. Feedback will be appreciated.

  • 2
    Basically OP stated they did ( a ), with no luck. – HasH_BrowN Nov 15 '14 at 7:56
  • 2
    Didn't work for my Moto E :( – Tom Brito Feb 10 '15 at 18:00
  • It didn't work on my LG G3 with CyanogenMod 12.1. I did only steps from 1 to 3 because I couldn't find Google Settings among applications nor under Settings. – Marco Lackovic Jul 4 '15 at 7:47
  • Didn't work for me. – UpTheCreek Aug 7 '15 at 6:42
  • Did work for me. Not sure if that was because of the exact instructions or just the memory that was freed up. – Peter Jan 25 '17 at 14:45

The problem you are facing is not uncommon. Namely Android operating system (like any other) provides different partitions for different usages, among them there is a partition for user installed apps ("apps partition"), and that partition is usually 1 GB or 2 GB or less (depending on the total memory of the device). And you do have only 28 MB on your internal storage where the apps are stored. Long story short, those 2 GB of free space you have are not meant for apps but for media files (pictures, videos, etc.).

There are two solutions to your problem:

  1. Moving apps from internal memory to sd card (not necessary external sd card). This will allow you to install apps on the internal memory while the data of the apps (which is usually bigger then the app itself) will be stored on your sd card. This is will give you a lot of free space for more apps of your choice. Downside is, every app you move to the sd card will not have a widget and will be slower to use. You can do this by installing App2SD from Play Store or any other app that can move other apps.

  2. Different approach requires more technical skills. You can root your device, and manually change the partitions so you get more space on your "apps partition", but reduce system partition or cache partition. This procedure is a bit tricky and is different for each device. If you decide to do this a good starting point is the XDA developers forum or simply google it for your specific device.

Hope this helps.

Your apps are installed to internal memory natively, thus the 28mb space left

  1. In your Settings → Apps click on an app and if it gives you the option to move to SD card, try it. Not all apps can be moved and some apps won't work right if moved, on that use your best judgement. There are also some apps you can find that will do the same thing for you if the move to SD card isn't an option.

  2. Thumbnails. This is refering to the SD card where there is enough space, but might be useful though:

    • a) You can find the file (usually here: /mnt/sdcard/DCIM/.thumbnails, or something close to that) in your system that is storing thumbnails, erase that - its usually pretty large. That will give some extra space.
    • b) Or if you not afraid to get into the system a little more you can do this for a more permanent fix. ** With this you be switching another file out for the thumbnail file. That way it can't be recreated.
  3. move any ancillary files (movies, music, photos, email attachments, downloads and etc.) to the SD card

EDIT If rooted, you might be able move /data/media/obb to SD card without errors.

  • I have enough space in both the internal and external cards, and the issue still persists. – Shimmy Nov 20 '14 at 10:58
  • @Shimmy - did you check your device out with a partition app? You should also check and see if maybe a partition is mounted or unmounted correctly. – HasH_BrowN Nov 20 '14 at 21:46

Try this, it worked for me.

Settings > Apps or App Manager > Google Play Services

Then, uninstall updates.

Try, downloading your app once again and it will work now.

However, you've to reupdate your google play for latest updates.

protected by Community Jan 1 '15 at 21:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.