0

I have a 2013 Nexus 7 that I'm trying to use to replace my laptop. I recently installed Linux Deploy and am running the testing distribution of Debian on the device. I've installed all my productivity suite, and things are so close to perfect. I have one small problem I'm hoping you can help with.

I have a few files, such as emacs org-mode agenda files, that I sync with Dropbox. I recently installed DropSync to download those files and keep them up to date on my device. DropSync allows 2-way synchronization, so editing them on my device should update them in Dropbox. I've set up a symlink to my DropSync'd folders to make it easier to access those files. Currently they are all stored in /storage/emulated/0/Dropbox, with the symlink in my home directory created with ln -s /mnt/0/Dropbox, because /mnt/0 is the mount point for /storage/emulated/0 from my Android fs.

The problem comes when I try to edit the files. Unless I use the sudo command in my Debian install, I only have read access to the files. When I run ls -l on a directory, I get the following:

-rw-rw----. 1 root aid_sdcard_r   0 Sep  3 12:46 filename.example
-rw-rw----. 1 root aid_sdcard_r 242 Sep  3 12:46 filename2.example

I've tried running chmod, but none of the permissions seem to change. is there a way I can permanently change the file permissions in directories I am syncing, so that I don't have to use sudo to edit the files?

The results of mount for the mount point of /storage/emulated/0 are:

/dev/loop15 on / type ext4 (rw,seclabel,relatime)
proc on /proc type proc (rw,relatime)
sys on /sys type sysfs (rw,seclabel,relatime)
selinuxfs on /sys/fs/selinux (ro,relatime)
tmpfs on /dev type tmpfs (rw,seclabel,nosuid,relatime,mod=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,seclabel,relatime)
/dev/fuse on /mnt/0 type fuse (rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other)

Results of mount in Android Terminal Emulator are extremely long. The one referring to /storage/emulated/0 is

/dev/fuse  /storage/emulated/0  fuse  rw,nosuid,nodev,relatime,user_id=1023,group_id=1023,default_permissions,allow_other 0 0

My username for the Debian instance is ryan.

  • Emulated sdcard is usually mounted as fat so you can't manage permissions inside. You might have to check how is that partition mounted. – Crayon Sep 5 '14 at 0:15
  • @Crayon Sorry if it's a dumb question, but how do I do that? – Ryan Sep 5 '14 at 0:34
  • np ;) Open a terminal and run: "mount" it should give you a list of all partitions mounted and their options. – Crayon Sep 5 '14 at 0:43
  • @Crayon I've added the results of the mount command. Seems to be using the "fuse" filesystem, if I'm interpreting correctly. – Ryan Sep 5 '14 at 2:20
  • I think situation might be more complicated than I expected, I am not familiar with chroot environment. I am not sure I can help you but I can try. Can you: * Post the full result of "mount" excuted from a terminal emulator on android (not inside debian). * Check if the same command issued inside debia gives you the same result, if not post that one too. * What's username in debian shell? ([username@host ~]$) * Where are originally files you want to edit and what did you symlink (files/directory)? – Crayon Sep 5 '14 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.