9

I recently bought a used Nexus 5. It came with the L preview on it, and I decided to flash CM 11 instead. My last phone was a Nexus S, and I've flashed various ROMs to that thing in the past.

Using the same machine that just re-flashed that Nexus S a couple weeks ago, I booted the Nexus 5 into fastboot mode, flashed ClockworkMod onto it and re-unlocked the bootloader. However, when I tried using ADB to push the CyanogenMod image over, I got error: device not found. Sure enough, adb devices fails to detect the device, even though USB debugging is enabled.

I decided this was just an issue with L, so I used Google's flash-all.sh script to give me a stock KitKat install. This worked fine, since it's pushing the image via fastboot. However, I still can't get the device to show up to ADB. When I enable USB debugging with the phone plugged into my computer, I don't get a fingerprint confirmation dialog, and no icon notification appears to indicate that it's connected to a computer. I've tried 2 different OSes (Windows 7 and Linux Mint 14) on 3 different computers with 4 different USB cables.

I've tried installing Google's USB drivers, and I have this problem with both fresh installs of the Android SDK and time-tested ones. I've already got 0x18d1 in my adb_usb.ini. On my Linux system, the output of the lsusb command gives identical output whether the phone is connected (with USB debugging enabled) or not. When it's in fastboot, it shows up as Bus 001 Device 069: ID 18d1:4ee0 Google Inc.

The phone seems to work perfectly fine in every other respect. I'm pretty happy with vanilla KitKat, but I'd be happier at least knowing I had the option to use something else. I also like having access to adb shell now and then.

I've seen plenty of people having issues with ADB before, but never without also having fastboot problems. Any ideas what might be going on? I'd prefer a Linux solution, but I can also work with Windows if needed.


Update: I was able to get the appropriate files into /sdcard/ by simply downloading them with a web browser, then flashing them with ClockworkMod. I'm now running CM 11, and the ADB problem hasn't gone away. Whatever is causing this, it persists through complete ROM replacements. I'm now curious as ever to know what could be causing this.


Update 2: Upon further communication with the ebay seller, it turns out this phone had been the subject of water damage prior to being listed for sale. The device booted and appeared to work fine, but in addition to this strange ADB issue, it also couldn't recognize a SIM card. It seems like this was some one-of-a-kind hardware damage, so I doubt there's even a solution.

I ended up returning the device, so there's no way for me to test anything else on it, but if anyone's able to come up with an explanation for why Fastboot can communicate with the device but ADB can't (again, probably due to a hardware fault), I'll accept that as an answer.

  • I'm facing a similar issue: Fastboot USB works (Linux and Windows), ADB doesn't. In dmesg I see the ADB device connects and almost instantly disconnects. When fully booted, then connecting, the device will never leave charging mode (thunder bolt icon remains). When booting with the PC connected, it will never enter charging mode. Even when connected to a wall charger afterwards. A reboot is required to fix this. A few weeks back it sometimes worked, and sometimes didn't. Now it just sticks with this issue. :-( – hurikhan77 Mar 13 '15 at 21:36
  • My Nexus 4 developed the exact same problem. It can work with fastboot, but not adb. It simply does not get recognized as a valid usb device of any kind unless in fastboot/bootloader mode. I'm going to try to replace the USB connector, but I'm not confident it will work. – chappjc Apr 20 '15 at 20:39
1

Flash ROM with Fastboot

Before starting ensure bootloader is unlocked. Obtain a ROM of your choice, and note the location on your computer.

  1. Reboot your device into fastboot mode via one of the following options.

    • adb reboot bootloader (requires USB debugging to be turned on). - for working adb; OR

    • power off the device then back on with 'vol up' + power button. - for nonworking adb

  2. Wipe your device. fastboot -w

  3. Update your ROM. fastboot update /path/to/your/RomFile.zip

  4. Your phone will update and automatically reboot into the new ROM


Edit:

Try the Universal Naked Drivers by 1wayjohnny over at xda forums.

This has been included because my researching has also found corrupted drivers can be the culprit

Try http://code.google.com/p/boot-unlocker-gnex/ to reset tamper flags.


The only other information I could find for the error: device not found is not helpful in this forum. It does lead towards development and programming though.

  • I tried installing 1wayjohnny's driver, but I'm getting the same results. A little clarification: In Windows, when the phone is booted (not in fastboot), it doesn't show up as an unknown device. It doesn't show up at all. If I reboot into fastboot, it then appears. – Dan Sep 7 '14 at 15:09
  • I tried installing using fastboot update and got error "update package has no android-info.txt or android-product.txt" – techie_28 Aug 20 '15 at 12:24
-2

The device has to be in MTP enabled state, regardless if in recovery or booted into the UI. Stock recovery defaults to enable MTP for the ADB bridge in case you didn't have a custom recovery.

In TWRP, and CWM you have to enable that option before adb will be detected by your Linux machine's adb.

  • What does Media Transfer Protocol have to do with ADB? Fastboot mode also general presents a specific interface that has nothing to do with any configuration on the phone -- most devices present as a generic Google/Android device while in Recovery or Fastboot mode. – Matthew Read Feb 15 '15 at 22:03

protected by Community Jun 4 '15 at 18:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.