7

I have an android phone running 4.2.2. I am using TP-LINK ADSL router and the connection is stable. But everytime I open an app that tries to access internet, my connection keeps connecting and disconnecting frequently. I have other phone running on same version of android but the connection is stable on it. What could be the problem. Any useful suggestions are welcome.

0

It may be due to other (open) WiFi signals "disturbing your device". With multiple APs being available (in range), your device might try switching to the strongest signal. Of course this would require your device had been connected to them before (Android doesn't automatically connect to "unknown" networks – but it does automatically connect to networks you've used before).

If there are networks in range you've used in the past, you could try to remove them from your "known networks": Go to Settings › WiFi, and check which networks are listed. Tap-and-hold each of them will reveal a context menu allowing you to edit or "remove" it. Chose the latter will tell your device to "forget" it has been connected here already, and thus to not automatically connect it. Just leave the one you want to use being "known" should rule out this cause.

  • What are "high range signals with open or inserted secured password"? Never heard of such. What should that have to do with "removing passwords" (what would that change on the signal level)? And where does it say the device is connected to more than a "single network"? – Izzy Dec 1 '14 at 12:57
  • I mean to say if in your range any other free router signals with high frequency may regularly connecting with your laptop may redirecting simultaneously. – technojohn Dec 13 '14 at 10:07
  • I think I get your idea: you mean if there are other APs around, the device might "frequently switch" to the strongest? Makes sense, but only partly: AFAIK, if there's a "password protected" connection established, Android shouldn't switch to "open networks" automatically. Especially not if none of them were used by you before (no auto-connect to those at all IMHO). So this could be the reason if there were multiple APs around which the OP had connected in the past already. Is this what you mean? – Izzy Dec 13 '14 at 11:50
  • yes, what you said right, but these thing is not working exactly with some mobiles as my samsung smartphone to having these issues, its automatically redirecting at some moment, but i'm not concentrating on these issues as i'm continuously getting the internet access from different open wi-fi over my home. – technojohn Dec 14 '14 at 6:27
  • To laptops we can put priority, but coming with mobiles i want to remove unknown access service from wi-fi list then it will be cool to avoid such issues. these what the thing i was explaining to you. – technojohn Dec 14 '14 at 6:29
0

It could be an issue with McAfee firewall; I put McAfee W-Fi security off for a few seconds and wow the wi-fi did not drop; now wifi is working as well as the McAfee wi-fi security is also put back as 'on'

  • 1
    He didn't mention though using a firewall. – user145490 Sep 14 '16 at 5:23
0

We have the same problem, but now I discovered the root of the problem. If you are connecting to a wifi with weak signal, or a wifi with many devices connected, then it is the cause. Whenever I tried playing games with a wifi with weak signal and many devices connected, it keeps disconnecting and connecting because our phone might too weak to accept wifi signal

0

There are all manner of issues that can affect WiFi performance.

  1. Noise Any other energy at frequencies used by your connection. This includes other WiFi devices but also other things like microwave ovens and wireless phones. You can try to set your AP to a channel that has less noise. The nonoverlapping channels you should set a 2.4 GHz WiFi AP are 1, 6, 11, and if your country allows, 14. In general, there is less traffic on 5 GHz channels, so these are a good option if supported by the AP and phone. Your AP may have an option to automatically change channels if it encounters a lot of noise.

  2. Hardware Some devices are poorly designed and require physical modification to work acceptably. This depends on your particular phone model. Check that the antenna(s) on the AP are properly attached, and play with their orientation. LifeHacker suggests to orient two antennas perpendicular to each other.

  3. Software/Firmware Install the latest updates, both for your phone and AP.

0

This post is a bit old but I came across the same issue recently and only the following solution worked.

Some versions of android have a wifi power saving mode which can come already activated when you buy the phone or by consequence of an activation made by an app (in my case it was the latter).

This mode will disconnect the wifi connection whenever it's not being used and reconnects it when you start using it again. I found that it does it quite frequently though.

But some connections have security settings that require you to manually log in to the connection every time you want to connect, in these cases I can assure you this little problem becomes a pain in the ass.

So what I found was that in order to disable it you should dial *#0011# then you hit the menu button and select Wifi. You will get a page with the connection details and there you'll find a label saying Wifi power saving mode and a button under it, turn this button off.

This did the trick for me, I hope it helps.

0

I used to have the same problem and here's what I did

1.Dial *#0011#

2.Then press the menu button and select wifi

3.You'll notice an ON button

4.Turn it Off

5.Restart phone

p.s.: When you restart your phone, recheck if it's still OFF, if not repeat til it works.

It has worked for me and now my wifi is connected all the time, I hope I helped.

  • 4
    Dialing *#0011# doesn't work on Nexus 5, could you mention your what's device model? – Andrew T. Oct 8 '15 at 2:39
0

I had a similar problem in that my tablets would connect/disconnect and my laptops would be just fine.

So here was my solution. This may or may not help but worth a try. You don't say what the other phone is. Different OS or whatever.

  • Anyway log into the router and look at the wi-fi settings.

  • First go to Accessories, Command Prompt, type in ipconfig and look at your gateway IP and put that number in your browser address bar and do a CR>. (I type in a different number than my Gateway IP, maybe because I have Mediacom as my IP provider)

  • Now you will see a box that comes up and something that calls for a Username & Password.
  • Type in ADMIN, PASSWORD. Either all CAPS or all lower case. If that doesn't work, just try the word "username". If that doesn't work then you need to call your IP and have them reset because ADMIN and PASSWORD is the default.

  • Anyway if you get in, go to SETUP Wireless Settings.Your channel should be on Auto, and your Security settings should be set to: WPA-PSK[TKIP] + WPA2-PSK[AES

  • Grant you I have an "older" router. There may be newer stuff out there. But since this is the only answer you got so far, it's worth a shot to try and see if it gets better.

The other problem may be a short in the antenna which means cracking open the phone and soldering it, possibly blowing the warranty. Actually, I don't think I'd mess with that myself unless I figured I had nothing to lose and had tried all other options. I'd also try using a buddie's Mi-FI or another cell as a hot spot and see if that works. If it's a no-go, it probably is the antenna.

  • okay, I solved it. I restarted my router when this type of behavior shows up. Is there any explanation? – Mula Ko Saag Sep 12 '14 at 7:12
0

Go into settings→ wifi, then uncheck 'smart network switch'.

-1

I just selected advanced on WiFi settings android.then I pushed the wps button on the router and at the same time tapped wps push button on android WiFi settings. So far my phone has not disconnected.

protected by Community Dec 24 '15 at 0:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.