I downloaded an APK and when I try to install it, the "install" button is completely unresponsive.

I have gone into the settings and enabled "Unknown sources" in the security section.

Is there something else I need to do?

I'm using a Galaxy S5 with Kitkat 4.4.2, unrooted.

marked as duplicate by Matthew Read Apr 24 '15 at 15:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Would you mind mentioning that .apk file? Is the 'Install' button greyed out? – MANI Sep 8 '14 at 10:27
  • No, the install isn't greyed out. Does it make a difference what APK file it is? – Questioner Sep 8 '14 at 13:49
  • No. I want to whether that apk is compatible with the android version you are on. – MANI Sep 8 '14 at 14:02
  • It could be corrupt, it could be damaged in some way, what way are you clicking it to open it? It could have a script to only install on rooted devices / different version of Android. There's not enough information to go on here tbh. – RossC Sep 9 '14 at 8:57

Disable your screen dimming app. :)

Some screen dimming apps work by overlaying the whole screen with a translucent window, and letting touch events pass through to the activity below, but for security reasons, you can't interact with system dialogs (such as the package installer) through another activity.

It sounds counter-intuitive, but it could be the cause. It's more likely than a corrupt APK file or a version incompatibility, either of which would cause an error message.

  • This worked for me. Very nice. – Alireza Noori Dec 24 '14 at 15:51
  • 2
    I wondered why this happened all of a sudden...but after seeing this, I realized I had installed one of those daylight filter apps (such as Twilight). – ravemir Jan 26 '15 at 18:04
  • I was not running a screen dimming app, but I closed all open apps, then the install button become responsive. What worries me is that something was running a transparent activity, capturing my touch events. – Jason Hartley Aug 23 '15 at 19:27
  • Update: Stopping SFinder on my Samsung S5 solved the problem. – Jason Hartley Aug 23 '15 at 19:41
  • 4
    Twilight was causing this issue for me, thank you! – Curtis W Feb 9 '16 at 2:49

Disable Verify Apps in Security. If that didn't help, you could just copy the apk file to /data/app/ and reboot the phone (as a temporary solution), also try Wiping the Dalvik Cache.

  • What? There is no 'verify apps' in security. – Igor G. Apr 7 '15 at 14:05
  • @Mervin I cant install apk from consumer.huawei.com/minisite/uk/fut/index.html I got the error "INSTALL_FAILED_SHARED_USER_INCOMPATIBLE: Package couldn't be installed in /data/app/com.huawei.betaclub-1: Package com.huawei.betaclub has no signatures that match those in shared user android.uid.system; ignoring!" – Maulik patel Sep 6 '17 at 11:15

Try to install it using adb. Download the Andorid SDK and then connect your phone to the PC via USB, make sure the USB Debugging option is ON under Developer Option in your phone settings.

Once you are done try to use these commands. adb devices to check the connection to your device and then if everything is OK try adb install <filename>.apk. Make sure you input the correct path to the file or simply copy the apk into adb directory.

adb usually resids into adt-bundle-$version/sdk/platform-tools

You can command prompt cmd in Windows or console in *nix based system.

if you received a warning,then Google can and does block apps that can be damaging,and or have malicious code in them. Google can even remove apps after installing as well. Find and read their policy on installing apks from other sources.

  • Not necessarily true. In my case, I am just trying to test an APK in the emulator. My own APK that I developed - and getting this error! – Igor G. Apr 7 '15 at 14:07

protected by Community Nov 23 '14 at 4:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.