The camera on the Nexus 5 has stopped working. Coming from a reboot, I can open the camera app, see the camera is working, but as soon as I click to take a picture (or video), the app crashes (tried native and Play Store camera apps), which I then have to force close, then when I reopen the camera I get the error "Can't connect to camera". The only way I've found fix that is to do a reboot, then the whole thing starts again.

This is the same if I use the front or back camera.

Does anyone know if there's a fix for this, or if Google are aware of it at least?

  • 2
    Please keep in mind that L is only a developer preview right now, and therefore is riddled with bugs.
    – dantis
    Sep 10, 2014 at 9:56
  • Yeah I know that, I was just curious if this was a known issue what maybe had a fix.
    – TMH
    Sep 10, 2014 at 9:58
  • A notice: We wish solutions that do not involve serious violations of the Linux philosophy. One of it is rebooting.
    – neverMind9
    Mar 25, 2018 at 21:28

3 Answers 3


Go to Settings » Developer options, and deselect "Use NuPlayer". Reboot the phone, and your camera should work again.

  • Perfect! Thank you. Do you know the reason the "Use NuPlayer" setting messes up the camera (just so I know the details)?
    – TMH
    Oct 29, 2014 at 14:24
  • @TomHart It is labeled "experimental" for a reason, I guess :)
    – neu242
    Nov 3, 2014 at 8:35
  • Haha true. I was just curious if you knew what it actually did that's all :).
    – TMH
    Nov 3, 2014 at 8:53
  • Didn't had that selected in first place. Still having this issue.
    – Aniruddha
    Nov 10, 2014 at 19:12

I've had this issue and tried the solution above to no avail.

I found that this issue is correlated to the flash. This approach fixed the issue for me:

  1. Pull down the accessories drawer from the top of your Nexus and tap the torch to turn on the flashlight. In my case the torch disappeared when doing this.
  2. Restart your phone.
  3. Go to the torch accessory again and turn on the flashlight and then off again. You might have to go into accessories from the lock screen if the torch still is gone.
  4. Now the camera works.

The issue can appear when turning the flashlight on and let it expire by itself, without turning it off. This is how I got to try this approach.


This happened again for me and this time it was Snapchat that crashed taking the camera with it. My solution above didn't work until Snapchat was updated again and that time it was needed.


If you know which app caused the issue you can resolve it by yourself by uninstalling it, do my trick and then re-install it. Although this might be cumbersome most times, it might be the only way out in case the app isn't updating often or at all.


Had this issue for months, very annoying. Rebooted numerous times, kept failing. Its to do with third party apps. I uninstalled Viber which is the only third party app I have that uses my camera. Perfect again now for over a week without a blip. Supposedly google have notified third party app developers of something they must update, some haven't updated their apps. Best of luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .