-1

I would like to know how to get rid of the message "your Internet connection is unstable?

3
  • 2
    Close it, or go offline? Honestly: we need much more context to answer that. Where does this message appear? What are you doing when it pops up? Does it happen on WiFi, mobile data, or both? Is it a system message, or thrown by an app? What makes you think it's specific to the Galaxy S4 (as you used that tag only)?
    – Izzy
    Sep 12 '14 at 8:58
  • I keep getting the error message on my cell phone, even when I am standing right on front of my wifi box. I tried control alt delete and deleting the cashe partition and it still didn't help. Any suggestions?
    – user69069
    Sep 12 '14 at 13:06
  • 2
    The one fact I get from your comment is it happens on WiFi (and that issue is called "weak internet" AFAIK). Now you need to provide a photo of your device: I've never seen an Android phone having Control, Alt, and Delete keys.
    – Izzy
    Sep 12 '14 at 14:00
1

There are a few potential things that can cause this.

  1. You are too close to the router. Seriously, this can happen on Samsung devices. I've seen it on the S4 and Note 3. It's very unlikely but worth mentioning on a list.

  2. The 2.4Ghz and 5Ghz are interfering with something on the device. Try turning 5Ghz off altogether.

  3. You could add the phone's ip address to the router's allowed devices.

  4. In the phone's network/wifi (varies by device/version) settings, untick auto switch between WiFi and mobile network

  5. As suggested here:

TP-link router has the ability to create a 'guest' network. So besides the 2Ghz network and the 5Ghz network, I created a 3rd network, only for the 2 mobile phones.

  1. In your router's LAN setup section you can add your phone to the section where it says Address Reservation

Not the answer you're looking for? Browse other questions tagged or ask your own question.