1

I have enabled UDB Debugging for my moto 360, but when I connect it to my computer, I don't get the "Allow Wear Debugging?" dialog.

How can I get this to show up?

1
  • I'm not super familiar with this, but I was under the impression that if you've enabled the developer options and your device and PC have exchanged keys per your initial authorization, it won't prompt and will simply work. Sep 14 '14 at 21:43
2

First of all become a developer on Moto 360 and enable Debugging.

  1. Launch Settings
  2. Select About
  3. Tap on Build number until you become a developer :-)
  4. Above will enable Developer options in Settings on your Moto 360

Enable ADB debugging and Debug over Bluetooth.

  1. Under Developer options enable ADB debugging and Debug over Bluetooth
  2. Launch Android Wear on your phone/tablet
  3. Press settings (gear) icon
  4. Turn on toggle button Debugging over Bluetooth
  5. Connect your phone via USB and make sure USB debugging is enabled
  6. Run adb devices from the command line.
  7. If device called “localhost:4444” is listed, you are already paired and can continue at step 13.
  8. From command line run adb forward tcp:4444 localabstract:/adb-hub then run adb connect localhost:4444
  9. Launch Android Studio. When you launch your app your device should be available in the list for debugging in Choose device dialog under Choose a running device checkbox.

Hope this helps.

1
  • 2
    Juan José Melero Gómez Suggested following note to step 12. Sometimes the terminal could return the following error message after executing the second command: unable to connect to localhost:4444: cannot connect to localhost:4444 no connection could be made because the target machine actively refused it (10061). In such case adb connect 127.0.0.1:4444 will do instead.
    – Erik Ušaj
    Nov 6 '15 at 9:07
1

Just an update to the above.

Google has removed the "Debugging over Bluetooth" option from the Wear OS app some time in 2021.

If you need to enable this feature, downgrade to an older version. I had success with https://www.apkmirror.com/apk/google-inc/android-wear/android-wear-2-36-0-318474873-gms-release/

0

For some reason it only worked when my phone (Moto G5s) was in "charge only" mode when connected via USB. As soon as I changed it to "file exchange" the connection broke and ADB refused to connect to the smartwatch. After switching the phone back to "charge only" and restarting the adb console I could connect again using "adb connect 127.0.0.1:4444"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.