I have a mind boggling problem which I have been trying to solve for the last few weeks. I am new to Android and recently bought Huawei Ideos X5 (Android 2.2.1). I haven't found anyone else having this problem.


My Android phone will be able to connect to my wireless network, get an IP address from my DHCP server, but when trying to reach anything over the network it won't work. Although it will work sometimes (i.e. some data will get through).


My Android phone is able to connect and use other wireless networks, although I have only tried two (at my university and at a friend). This would indicate that my phone is not broken.

With closer inspection with the Terminal Emulator App when I ping my server I will get a 80% packet loss ratio. This of course makes it impossible to use the wireless network, but it means some packets do get through (even to the Internet) so it is not a DNS problem.

My laptop can connect and use my wireless network flawlessly (in fact, it can download from Internet at 18 Mbps and upload at 10 Mbps with 802.11g, which I presume is good). My USB wireless adapter works well with it as well. One of my friend's Android phone (LG Optimus One) and iPod works with my wireless network as well, and most strangely, another friend's Android phone who have the very same model (Huawei Ideos X5) works with my wireless network. This would indicate that my access point is not faulty.

There are tons of wireless networks in my area. My phone can see 21 including my own. I have no idea whether this can affect anything. I cannot try any of these because they are protected.

It is worth mentioning that I do not have your average wireless network setup. I have a server (stationary computer) that runs DHCP server, and so on. Only recently I added wireless network to my apartment by buying D-Link DIR-300 and flashing it with DD-WRT. I have no idea if it worked or not with the original firmware. The router acts as an access point.

I have tried to change channel, protocol (B, G, N) , security settings from open to encrypted (WPA2 AES), etc. on the AP to no avail.

Even if the phone is just a few centimeters away from the AP it will still have a 80% packet loss. DD-WRT reports 92-98% signal strength. I think there is a software/setting problem and not a hardware one.

And of course, I have tried to both reset my AP and my phone. Neither helped. Android phone's WiFi does not work when the router is using the factory default or AP settings. I am however concerned that some faulty settings for my wireless network are stored on the phone and it seems they might be synchronized to my Google account, and possibly they might still be there even after I "forget" my wireless network or reset the phone (is there a way to be sure everything is wiped?).

At this point, I am out of ideas. I hope I explained my situation sufficiently. Do you have any ideas? Thanks in advance.


I have done some further testing. I reset the DD-WRT router once again to see if it would work and per Ryan's suggestion try to strip it down to the most basic setup. It did not work even if I tried only b/g mode. Interestingly enough the first two seconds of pinging after changing mode works without any packet loss but after that, it will go back to bad again.

I also tried something I wouldn't believe would work -- flashing the original firmware back. To my surprise it did work and my phone doesn't have any packet loss when pinging. (I actually missed that the original firmware does support AP mode). However, I still cannot understand why it didn't work in DD-WRT and would be very interested in any possible explanation.

As stubborn as I am, I might try to flash back to DD-WRT again tomorrow to see if it works (if it does, I cannot explain why! Blaming it on bad flash seems naïve in my opinion).

  • 1
    it might be a good idea to strip down everything to the simplest possible setup, i.e. use open (unencrypted) IEEE 802.11b/g; then add up encryption from there. Also, make sure to temporarily disable mobile network (2G/3G) so that your test ping does not went through there. What happens when you ping your router/access point through its IP address, do you still have packet losses?
    – Lie Ryan
    Apr 14, 2011 at 8:42
  • @Lie Ryan Thanks for your comment! When pinging I am using internal IP addresses ( so it is not possible for the traffic to take any other route. I have tried your suggestion and updated my post.
    – Nömmik
    Apr 14, 2011 at 22:05
  • I might be having similar trouble as you describe. I just posted a question about it. Sep 17, 2011 at 10:18
  • Unfortunately I still have no clue to why I had the issue. As I updated, flashing back to original firmware fixed my issue which would indicate a software problem. Question is from what end (or both)? I want to say my android phone since the router worked for all other devices. On the other hand, my android phone worked with all other wireless networks as well...
    – Nömmik
    Sep 17, 2011 at 11:54

3 Answers 3


Have you scanned the WLAN frequencies to see how strong is your own AP in relation to the other ones? I used Android program called Wifi Analyzer that does that; it shows you visible APs and their channels, and how badly their signal leaks into other channels. You can also see signal strength of you AP from that.

The mobile phone often has a lot crappier Wifi antenna than laptop, just because it needs to be smaller and lighter. Also, the orientation of the device varies more.

If you problem is signal strength, or other networks overlapping yours, changing channels or installing better antenna can help a lot. In this case I direct you to look at a sister site.

And, to me your setup sounds pretty geek-normal! I, too, use a Linux home server as AP, with PCI-E and USB Wifi adapters and hostapd.


I've been having problems similar to Nommik's with my Samsung Gio S5665. It would connect perfectly to the Wi-Fi at the office, but at home: connects with excellent to good signal strength, but pinging the router produces no response usually; occasional random bursts of return packets for 4 to 10 seconds; disabling and reenabling wifi on my phone results in 100% packet return for about 60-180 seconds, then back to occasional bursts.

All other devices including other phones connect to the home Wi-Fi correctly.

What I tried:

Changing protection on router from WPA/WPA2 to WPA only, WPA2 only, WEP only, none. No difference. Encryption from TKIP to AES: No difference

Changing channels, sideband, power, beacon rate, in short, everything changeable: No difference or worse.

On the phone: Changing ip address to static. No difference.


Flashing the router worked. I'm so happy now! This has taken weeks to sort out.


Had this just now with a 'fake' AP set up on a monitor mode interface with airbase-ng, couldn't figure out why with either DHCP or static IP there was 90% packet loss (with tiny bursts of connectivity loosely connected to screen wake up)...rebooting phone and reseting wifi of little help.

--then, after hours of fiddling, i swapped the RT2870/RT3070 USB wireless dongle against a RTL8187 one that was also lying around. Bo0m problem fixed, no more packet loss, with or without screen turned on, what the heck. Reporting with SK17i Xperia Mini Pro on Android 4.0.4 (Build 4.1.B.0.431).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .