0

I want to add new contact and save it in SIM Card.

I use OnePlus One with CyanogenMod 11S, which is on top of Android 4.4.4 and inside I have O2 pay-as-you-go card from UK. When I used Gingerbread and Ice Cream versions of Android in the past, I always had 3 options when creating contacts - Google account, Device and Sim.

Now when I tap on New contact icon, I cannot change the type from Google contact to anything else (tapping it just doesn't do anything).

I know this might be stupid question, but I cannot check it with other card. My real question is - is this problem specific to O2 (carrier), or Cyanogen, or Android 4.4? Or am I doing something wrong and there is some option I need to enable first?

  • I don't know about SIM (I no longer use it to store contacts or SMS for ages). But I've noticed some newer devices/Android versions seem to offer "Google only" for contacts. A work-around (if you don't want to store contacts in your Google account) would e.g. be using an app like MyLocalAccount to create a local account to use instead. – Izzy Sep 17 '14 at 13:30
0

After some investigation, I believe this in Android 4.4 issue.

It seems to be designed to use only Google contacts, synchronized with Gmail. I could not find any option to even display SIM contacts - they can only be imported from SIM to Google.

I know for sure, that in Android 4.2 devices, user can choose between location of contacts and can display all contacts, regardless of where they are saved.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.